-   Linux From Scratch (
-   -   cannot find XF86_S3 in XFree-4.2.0 (

fend88 05-04-2002 11:17 PM

cannot find XF86_S3 in XFree-4.2.0
I installed XFree 4.2.0, after installation, my XFree86 could'nt run due to XWindows can't find the compatible vga-card (S3 Trio64V2).

Now I'm copying the older version XF86 from my old Mandrake (XF86_S3 - older x version), run it with version 4.2.0 and modify the config file.
The Xwindows can run but is that the correct way? The configuration different from version 4.2.0 or is there other way to create to make version 4.2.0 support my vga card.

I had installed window maker and netscape 6.0, everything seems to work fine.

Any comment and correction is much appreciated. Thanks.

lfslinux 05-06-2002 11:50 AM

Running an XF86_S3 binary from XFree86-3.3.x on a X-4.x system may not have the desired results. If it works, it works, but I would still not recommend it.

All drivers supported under X-3 should work under X-4.2.0 as well. First of all make sure you have the s3 driver installed. Look for the /usr/X11R6/lib/modules/drivers/s3_drv.o file which is the S3 X module.

fend88 05-07-2002 04:20 AM

Thanks. Now I'm still working on it.

I tried to use XFree86 to configure but I cannot set the screen to 16 / 32 bit color and cannot display nicely (sorry, I don't know how to use that word correctly in English - got noise or grabble or something like that :o).
With xf86cfg, it showed that the vga card was not supported.
With xf86config, after configuration, xwindows can't load the driver.
Now temporary I make two files, one for xfree86 and another one for XF86_S3 (hopefully don't crash :) ).

lfslinux 05-07-2002 06:34 AM

X may wrongly think your card isn't supported. You're best off reading through the S3 driver documentation somewhere in the XFree86 source tree and see which cards they mention. then don't run the automatic configure thing, but do a manual setup of X and make sure you setup your monitor properly in regards to the horizontal and vertical scan/refresh rates. If they are not set properly, X won't allow you to use certain resolutions (or if they are set too high you may do damage to your monitor).

fend88 05-08-2002 01:11 AM

Thanks, now my XFree86 is working fine.
FYI, I only can use vesa driver for my S3 Trio64V2, I tried s3 driver but cannot work.



All times are GMT -5. The time now is 06:40 AM.