-   Linux From Scratch (
-   -   Can start xterm/Terminal as root but not as normal user (

Keith Hedger 07-05-2012 07:54 AM

Can start xterm/Terminal as root but not as normal user
Basically what the title says I am running xfc4.10, X starts fine for normal user and I can run xapps ( chrome, spacefm etc ), but if I try to run xterm I get a blank window with a cursor that does nothing, if I try to run Terminal (the xfce version) it flicks up then closes.
If I login and start X as root every thing works fine, if I open a terminal ( xtrem or Terminal ) and su to my normal user account and the try to start a new xterm i get this error:Cannot chmod /dev/ttyp1 to 666 currently 620: Operation not permitted ( and yes I have tried setting the permissions first but the don't stick )
and a dead window again, both the root and user are members of the same groups:bin sys kmem tty tape daemon floppy disk lp dialout audio video utmp usb cdrom console cdrw mail news users
If I run in a chroot environment every thing is fine.
I have tried creating a new user in case the problem was with permissions but got the same results.
I am working from this:
Aside from this and automounting ( which is a whole 'nother kettle of fish! ) everything seems to be working fine.

Keith Hedger 07-06-2012 05:34 AM

Well after a LOT of googling and rebooting I found the answer the /dev/pts folder was not being created so after adding it to /lib/udev/devices so that it gets created in /dev by udev early on in the boot, everything now works fine. :)

ssanthshtech 05-21-2013 04:08 AM

disabling root
hi i 2 have same problem

From Linux From Scratch build a minimal system for running my application with xinit. But struck on disabling root permission.

Need my minimal lfs as ubuntu.

when ubuntu boots login-screen comes then we enter username and password it will redirect to Desktop from ter when we open a terminal, Terminal will open as $--> non root-user from ter we access #--> root via sudo or su.

Same as ubuntu when my lfs boots want to display my application [xinit-window launcher (same as login screen in ubuntu but, in my case without asking user name and password {autologin})] after that when i access terminal it should display as $--> non-root user then i want to use sudo to access root.

Help me to solve this somehow similar to ur problem.

Keith Hedger 05-21-2013 05:35 AM

This post:
will help with the auto login, as for disabling the root account, why? just set a good password ubuntu's ridiculous disabling of the root account and banning anyone on their forums for even hinting at how to enable it is one of the main reasons I stopped using ubuntu years ago!

All times are GMT -5. The time now is 04:28 PM.