-   Linux From Scratch (
-   -   Bootsplash compile error (

muppski 10-31-2005 06:24 PM

Bootsplash compile error [Solved]
I'm trying to compile Bootsplash and I get this error


root:# make
gcc -Os -Wall -I/usr/include/freetype2  -c -o ttf.o ttf.c
In file included from ttf.c:13:
/usr/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h' hasn't been included yet!"
/usr/include/freetype2/freetype/freetype.h:21:2: #error "Please always use macros to include FreeType header files."
/usr/include/freetype2/freetype/freetype.h:22:2: #error "Example:"
/usr/include/freetype2/freetype/freetype.h:23:2: #error "  #include <ft2build.h>"
/usr/include/freetype2/freetype/freetype.h:24:2: #error "  #include FT_FREETYPE_H"
make: *** [ttf.o] Error 1

I recompiled Freetype2 to be sure but same error

[|RoA|]RoadRunner 10-31-2005 07:52 PM

Hi muppski,

maybe the following link give a solution for Your Problem:

Sincerely, RoadRunner.

muppski 11-01-2005 07:17 AM

Aah thanks
Why didnt I find this page while googling? =)

muppski 11-01-2005 08:23 AM

Next error

gcc -Os -Wall -I/usr/include/freetype2 -L/usr/lib -o splash -L/usr/lib splash.o /usr/lib/libmng-mini.a -lz -lm
gcc: /usr/lib/libmng-mini.a: No such file or directory
make: *** [splash] Error 1

I have recompiled libmng to be sure (according to blfs) but there is never a libmng-mini.a !!!

muppski 11-03-2005 03:11 PM
There was a patch for this error

All times are GMT -5. The time now is 11:37 PM.