-   Linux From Scratch (
-   -   Boot Msg : Setting up Linux console... [ FAIL ] (

R3D 07-17-2011 01:28 AM

Boot Msg : Setting up Linux console... [ FAIL ]
(Using lfslivecd-x86-6.3-r2160)

As the title says, I've got a small problem at boot, however the system continues to boot normally without any further problems, I end up with a wrong keyboard layout ( querty instead of azerty ).
I've been trying to look what went wrong, but can't seem to get it solved.

Here are some parts of the my configuration values:


KEYMAP="be-latin1 euro2"
FONT="lat0-16 -m 8859-15"

# I also quicklly tried these, tough I always used the above in the past with succes
FONT="lat0-16 -m 8859-15"


export LANG=nl_BE@euro

(Chapter 8.3) linux- kernel compiled with :

export LANG=nl_BE@euro
make LANG=$LANG LC_ALL=POSIX menuconfig
# tough I'm not sure I did set LC_ALL=POSIX in the past,
# could be I left this one blank before.

btw, I use LC_ALL=POSIX to surpress the translations,
( try searching for solutions in none-english, good luck ).

This has always worked in the past, but not now, does someone know what the problem could be and if there is a solution to 'quick-fix' this issue,
( this is being build on a system with a 400mhz cpu, so it would be very time consuming to start again from... scratch )

Thanks at front,

Marlino 08-01-2011 12:59 PM

Looking at the title

Originally Posted by R3D
Setting up Linux console... [ FAIL ]

it seems, something goes wrong while your system
is running /etc/rc.d/init.d/console.

So you could put some debugging code there, to find out what is happening in more detail.
(And remove it, once you solved the problem.)

I believe echo will work nicely there.

edgezors 08-02-2011 12:23 AM

Chapter 6.47 has a note for installing Kbd-1.12


For some languages (e.g., Belarusian) the Kbd package doesn't provide a useful keymap where the stock “by” keymap assumes the ISO-8859-5 encoding, and the CP1251 keymap is normally used. Users of such languages have to download working keymaps separately.
Not sure if this applies to you or not, if it does you might not of installed your keymap, because it was not included by default.

Hope this helps.

All times are GMT -5. The time now is 01:01 AM.