-   Linux From Scratch (
-   -   book 6.8 section 6.9.1 (

mreff555 09-15-2011 06:20 PM

book 6.8 section 6.9.1
So I'm installing glibc. up to this point I have had very little problems but I got all kinds of errors now.

here is the printout of "grep Error glibc-check-log"

Any advice?

druuna 09-16-2011 01:34 AM


I can only assume that you fixed the problems you had and that all leading up to chapter 6.9 is ok.

A few errors are to be expected when doing this chapter and some aren't mentioned in the book, but your output shows way to many errors.

First thing that comes to mind are time-outs (did you try the TIMEOUTFACTOR=16 make -k check as mentioned in the book?).

Have you looked at the generated log files to see what the actual errors are, the posted output only shows that errors occurred, not why.

Hope this helps.

mreff555 09-18-2011 07:04 AM

Well. After deleting the build directory and archive and re-extracting glibc I still get errors but much less. I tried that timeout thing as well which is probably the actual reason why I'm seeing improvement.

make[1]: Target `check' not remade because of errors.
make[1]: Leaving directory `/sources/glibc-2.13'
make: *** [check] Error 2
root:/sources/glibc-build# grep Error glibc-check-log
make[2]: [/sources/glibc-build/posix/annexc.out] Error 1 (ignored)
make[2]: *** [/sources/glibc-build/rt/tst-cputimer1.out] Error 1
make[1]: *** [rt/tests] Error 2

Here is a direct link to the log

Any Suggestions?

druuna 09-18-2011 10:48 AM


If posix/annexc.out and rt/tst-cputimer1.out are the only 2 errors:

- annexc.out -> Can be ignored (mentioned in the message and in the LFS book),
- tst-cputimer1.out -> This one probably falls into this catagory: The nptl/tst-clock2, nptl/tst-attr3, and rt/tst-cpuclock2 tests have been known to fail. and can also be ignored (timing issues that are not very well understood, see the LFS book).

My advise: Continue with the build.

Hope this helps.

mreff555 09-18-2011 10:53 AM

Thanks I was trying to work up the confidence to come to that conclusion on my own. I noticed the remark about annexc.out.

As for the rt/tst-cputimer1.out I've hunted all over the net. seems like a common problem without a solution.


mreff555 09-18-2011 10:59 AM

On a side note I couldn't help but notice that compared to other posts with this problem. Most of the posts I found had difference magnitudes of .1 to 1... where mine is only .00007
I don't really know what that means. but I would thing that would be better. :)

clock_gettime returned timespec = { 0, 399318 }
clock_getres returned timespec = { 0, 1 }
*** timer sig1 invoked too soon: 3.401198981 instead of expected 3.401268129

All times are GMT -5. The time now is 09:06 PM.