LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
LinkBack Search this Thread
Old 09-09-2012, 08:25 AM   #1
kkt
LQ Newbie
 
Registered: Aug 2012
Posts: 6

Rep: Reputation: Disabled
BLFS OpenLDAP-2.4.32 make test error


Hi,

I am following the procedures on BLFS (after the building of LFS 7.2) to install the openldap server.
'make depend' and 'make' both succeed but 'make test' always fails. The failure point was different from time to time, sometimes it failed at test003, sometimes at test013 and etc.
Later, I found that 'netstat -a' reported a lot of TIME_WAIT connections during 'make test' and those connections were generated by the openldap test scripts.

Does anybody have experience about that? How can I solve the problem?

Thank you
 
Old 09-09-2012, 08:34 AM   #2
kkt
LQ Newbie
 
Registered: Aug 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
I forgot to mention there were many "Waiting 5 seconds for slapd to start..." messages during "make test".

Thank you
 
Old 10-22-2012, 12:48 AM   #3
kkt
LQ Newbie
 
Registered: Aug 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi,

I have tried to search a solution to solve my issue but still cannot get an answer.
I have also tried to modify the test scripts to make the tests wait more time for the "lt-slapd" process to start properly and completely but I am still wondering if there is something wrong in my system.

Actually, the problem I have is that even though the "lt-slapd" process can start up but it needs to take some more time (sometimes up to 30-40s) to listen on a port (e.g. 9011, 9012...). As a result, there are many "Waiting 5 seconds for slapd to start..." during "make test".

Can anyone give me an idea how I can solve the problem?

Thank you
 
Old 10-22-2012, 10:28 AM   #4
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 727

Rep: Reputation: 166Reputation: 166
Probably a stupid question but are you building the server or just the client if it's just the client the tests may not work.

If it builds and installs fine try skipping the tests and see if all goes well, if not you will have to track down the problem.
 
Old 10-27-2012, 06:40 AM   #5
kkt
LQ Newbie
 
Registered: Aug 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi Keith,

The build includes the server.
Finally, I give up the 'make test' and proceed to install. It seems no problem so far.

Thank you for your advice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BLFS BOOK chapter 19 openssh test suite spiky0011 Linux From Scratch 5 05-14-2011 12:18 AM
OpenLDAP 2.4.13 make test does not finish lite123 Red Hat 20 01-22-2009 01:01 PM
LXer: OpenLDAP Quick Tips: Always 'make test' LXer Syndicated Linux News 0 12-04-2008 06:10 PM
openldap make error 1 ikinnu Linux - Software 14 06-12-2008 03:59 AM
BLFS 6.1: Gnome-vfs-2.10.1 make error Lenard Spencer Linux From Scratch 1 08-29-2006 06:33 AM


All times are GMT -5. The time now is 07:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration