LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (https://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   BLFS OpenLDAP-2.4.32 make test error (https://www.linuxquestions.org/questions/linux-from-scratch-13/blfs-openldap-2-4-32-make-test-error-4175426362/)

kkt 09-09-2012 09:25 AM

BLFS OpenLDAP-2.4.32 make test error
 
Hi,

I am following the procedures on BLFS (after the building of LFS 7.2) to install the openldap server.
'make depend' and 'make' both succeed but 'make test' always fails. The failure point was different from time to time, sometimes it failed at test003, sometimes at test013 and etc.
Later, I found that 'netstat -a' reported a lot of TIME_WAIT connections during 'make test' and those connections were generated by the openldap test scripts.

Does anybody have experience about that? How can I solve the problem?

Thank you

kkt 09-09-2012 09:34 AM

I forgot to mention there were many "Waiting 5 seconds for slapd to start..." messages during "make test".

Thank you

kkt 10-22-2012 01:48 AM

Hi,

I have tried to search a solution to solve my issue but still cannot get an answer.
I have also tried to modify the test scripts to make the tests wait more time for the "lt-slapd" process to start properly and completely but I am still wondering if there is something wrong in my system.

Actually, the problem I have is that even though the "lt-slapd" process can start up but it needs to take some more time (sometimes up to 30-40s) to listen on a port (e.g. 9011, 9012...). As a result, there are many "Waiting 5 seconds for slapd to start..." during "make test".

Can anyone give me an idea how I can solve the problem?

Thank you

Keith Hedger 10-22-2012 11:28 AM

Probably a stupid question but are you building the server or just the client if it's just the client the tests may not work.

If it builds and installs fine try skipping the tests and see if all goes well, if not you will have to track down the problem.

kkt 10-27-2012 07:40 AM

Hi Keith,

The build includes the server.
Finally, I give up the 'make test' and proceed to install. It seems no problem so far.

Thank you for your advice.


All times are GMT -5. The time now is 12:26 AM.