LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 11-13-2005, 02:27 PM   #1
lik
Newbie
 
Registered: Jan 2005
Posts: 8

Rep: Reputation: 0
BLFS: firefox seg fault


Hi all,

I use LFS 6.1 and BLFS 6.1. I have problem when starting firefox:

/usr/lib/firefox-1.0.7/run-mozilla.sh: line 159: 3931 Segmentation fault "$prog" ${1+"$@"}

I have xorg installed and the twm coming with it. I have only installed those packages that is required for firefox as mentioned in BLFS book. Instead of firefox 1.0.6 mentioned in the book, I tried 1.0.7.

Can anybody help me with this problem? Or any hint?

If there are threads in the same topic, please point me there. I did search the forum but didn't see any discussion.

Thanks,

Lik

Last edited by lik; 11-13-2005 at 02:28 PM.
 
Old 11-13-2005, 04:12 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Have you configured fontconfig to find your fonts?
Code:
cat > /etc/fonts/local.conf << "EOF"
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->

<fontconfig>
<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>
<dir>/usr/X11R6/lib/X11/fonts/Type1</dir>
</fontconfig>

EOF
 
Old 11-13-2005, 08:26 PM   #3
lik
Newbie
 
Registered: Jan 2005
Posts: 8

Original Poster
Rep: Reputation: 0
It works. Awesome! How does the font setting have anything to do with the seg fault? It is really hard to guess from the error info.

Thanks a lot!

Lik
 
Old 12-22-2005, 11:57 AM   #4
Vincentcosmo
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
Lightbulb

I have the same error, but it is due to a ics file.

Strange, I modified my calendar through Thunderbird->calendar, closed it.
Later, I try to launch, calendar crashs!

- reinstall calendar does not change anything
- add the fonts path you proposed, anymore
- move my calendar ics file -> yeah!

So I've created a new calendar, import the old one by the "Import" function of the "File" menu, and all goes right.


Vincent
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install firefox seg fault!!! hfcmit Slackware 1 01-16-2005 10:56 PM
mozilla/firefox seg fault errors Zero-0-Effect Linux - Software 8 12-22-2004 12:06 PM
C seg fault drigz Programming 5 10-01-2004 04:35 PM
seg fault on fclose (); lackluster Programming 4 06-28-2003 08:30 PM
gnome_app_create_menus seg fault in RH 7.3 Castro Programming 0 05-30-2003 09:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration