LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (https://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Adding Package To Buildroot (https://www.linuxquestions.org/questions/linux-from-scratch-13/adding-package-to-buildroot-4175451133/)

kells 02-21-2013 10:08 AM

Adding Package To Buildroot
 
Hi guys, my question relates to buildroot, I wasn't sure of the most appropriate place to put this, but I thought since buildroot compiles a custom linux version here would be the best place.

I'm trying to add a package to buildroot, but I'm not having much success. The package I'm trying to add is an autotools package called scew. I've followed the buildroot guidelines about adding packages, and although the package is listed when make menuconfig is run, when I run make the package is missing from the final rootfs.tar.

I've also copied over another simple .mk file that's used to install which, and changed the variable names and URL accordingly. Here is my copy of scew.mk:
Code:

SCEW_VERSION = 1.1.3
SCEW_SITE = http://savannah.nongnu.org/download/scew/
SCEW_LICENSE = GPLv3
SCEW_LICENSE_FILES = COPYING

$(eval $(autotools-package))

In the same directory I have Config.in, which looks like:

Code:

config BR2_PACKAGE_SCEW
  bool "scew"
  help
  google scew

I've also added the following lines to package/Config.in:

Code:

menu "My Packages"

 menu "Packages I Wrote"
 source "package/MyPackages/packagesIWrote/hello/Config.in"
 source "package/MyPackages/packagesIWrote/helloworld/Config.in"
 endmenu

 menu "External Packages"
 source "package/MyPackages/external-packages/scew/Config.in"
 endmenu

endmenu

This part seems to work, as the packages are listed and can be selected. The hello and helloworld packages are copies from a guide to adding packages, taken from this website (written in french):http://www.linuxembedded.fr/2011/03/...-en-5-minutes/

The hello world packages also do not work. I'd be glad of any advice at all, as it seems I'm just going around in circles on this one, and I can't see what I'm doing wrong.

Thanks,
James

Keith Hedger 02-21-2013 10:51 AM

This probably needs to be moved to:
http://www.linuxquestions.org/questi...ux-software-2/


All times are GMT -5. The time now is 12:36 AM.