Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 03-29-2010, 10:51 PM   #1
LQ Newbie
Registered: Mar 2010
Posts: 6

Rep: Reputation: 0
5.15 compiling bash: configure script hangs at "checking where .elc files should go"

I'm making LFS from the SystemRescueCd 1.4.0, a LiveCD. Things have been going well except I'm now trying to compile bash-4.1 using the temporary toolchain. For reference:

I'm compiling this as the nonsuperuser 'lfs' as specified, and I've got the standard symlink from /tools to /mnt/lfs/tools.

lfs@sysresccd /mnt/lfs/sources/bash-4.1 $ ./configure --prefix=/tools --without-bash-malloc
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for emacs... emacs
checking where .elc files should go...
The script hangs here with no further response. I've tried unpacking the source again a couple times, with no change in behavior. I tried looking at the configure script source, but my bash-fu is not strong enough.

Your help's much appreciated.

Last edited by nescalona; 03-30-2010 at 01:32 AM.
Old 03-30-2010, 06:26 AM   #2
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,504

Rep: Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640Reputation: 3640
Usually no problem : Emacs is not a requirement ..

' ./configure --help ' : No options for emacs.
You can try : --disable-emacs --disable-xemacs
.. or just uninstall your emacs ( and xemacs ).

Then configure will reply ..
checking for emacs... no
checking for xemacs... no

.. And that is OK.
1 members found this post helpful.
Old 03-30-2010, 04:18 PM   #3
LQ Newbie
Registered: Mar 2010
Posts: 6

Original Poster
Rep: Reputation: 0
I'm running from a LiveCD, so emacs uninstallation is a hassle. I tried --disable-emacs, --disable-xemacs, and --disable-qemacs (my LiveCD has qemacs), but none were recognized.

Is there a way to effectively remove emacs from my current boot session, but of course without changing the CD contents?

EDIT: Ah. Removed the symlink /usr/bin/emacs -> /usr/bin/qemacs and all was well. Many thanks!

Last edited by nescalona; 03-30-2010 at 04:38 PM.


bash, configure, lfs

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 7 12-19-2015 02:03 AM
./configure script hangs at "checking for ICMP ping syntax..."l khilari Linux - Software 4 11-12-2011 11:27 AM
How to write a simple BASH script to "test if have folowing files, than delete."? hocheetiong Programming 10 10-01-2009 01:17 PM
Mandrake 10.1 hangs at "Checking root file system" while booting ananya Mandriva 1 03-01-2006 07:03 PM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 03:32 PM > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 11:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration