-   Linux From Scratch (
-   -   [LFS 61][failed fsck] with reiser file system (

mr_demilord 09-19-2005 02:35 AM

[LFS 6.1][SOLVED][failed fsck] with reiser file system
Everytime I fire up LFS 6.1 I get a failed warning. I installed LFS 6.1 on a reiserfs.
When I press enter it boots further and everything is fine.
I checked the disk with my SuSE 9.3, and it says the filesystem is clean and there arent errors.
LFS runs fine except the above.
It also notes me that the error is in S30checkfs.
and I checked the <checkfs> script, but I cannot find any error.

PS it's a journaling filesystem is it safe to delete the whole script without consequences?

mr_demilord 09-19-2005 04:12 AM


Looked again in the script and saw it was calling up fsck, took a look in the sbin and noted there wasnt a file called fsck, but I saw a file reiserfsck, so I created a symlink from the reiserfsck called fsck, and everything works like a charm.

Now further with blfs !

axion0917 10-12-2005 11:43 PM

If you don't have fsck, it means you don't have e2fsprogs...which means you didn't install LFS completely. Even when using ReiserFS (good choice BTW), e2fsprogs is needed for certain things...which is why it's in the LFS book (you shouldn't skip anything in the LFS book).

mr_demilord 10-13-2005 04:56 AM

reiserfsprogs has a fsck program, I created a symlink fsck to the reiserfsck and it worked brilliant.
LFS runs very smooth and I'm currently busy with configuring and installing the packages I need and some basic libraries. :D
And damn it's lightning fast, it's the best distro ever!

All times are GMT -5. The time now is 02:20 PM.