-   Linux - Enterprise (
-   -   Wine installed a program onto my windows partition, Windows BSOD on boot. (

DJGCrusader 01-08-2008 06:18 AM

Wine installed a program onto my windows partition, Windows BSOD on boot.
To make a long story short, I made the virtual C/ drive in WINE /media/sda1 (my real Windows C drive). stupid, stupid, stupid. Now I cannot uninstall the program using "uninstall Wine Software", and I get this BSOD every time i boot into Windows:

Stop: c000021a {Fatal System Error}
The Windows Logon System Process terminated unexpectedly with a status of (0x00000000 0x00000000)

It's definately the change of installed programs in my registry, but how do i diagnose it in the first place?


pixellany 01-08-2008 06:41 AM

I'm not qualified to be much help here, but I am curious.....I assume that you simply mounted your real C drive (sda1?) to ~/.wine/drive_c. When you installed something after doing that, did it work? If so, why would you not be able to uninstall it?

DJGCrusader 01-08-2008 06:18 PM

Well, it RAN but i got a random error, and it closed. And for WINE, i didnt "mount" anything. Unless i did, (if then stupid me lol) but in the preferences "Drives" tab, you can choose what drives are displayed/effected by the Windows Emulator. I made /media/sda1 my C:/ drive, and the /home/blah/.wine/drive_c/ i made the virtual D:/ drive. I tried reinstalling it, and the installer won't run if i make the default C:/ the /.wine/drive_c, only if it is the /media/sda1/ folder.
gah... I don't have any windows install CD of any sort, and my XP image comes standard with the school, but the IT guy at school doesn't ask any questions and simply reimages the hard drive. Any idea of what live cd i could use to diagnose and fix my predicament? Or how i can do it while running ubuntu? or even how to get Wine to work?

DJGCrusader 01-19-2008 03:13 PM

Does anyone want to help me out here?

gankoji 01-19-2008 03:32 PM

honestly DJG, the best way to handle this is to back up your data and let the IT guy at school do his thing. The problem is that you allowed WINE to use its virtual registry on top of the registry already found on the C drive, which more than likely caused windows to have a fit. Also, there could have been a conflict with WINE writing to a NTFS partition, although I don't know about that. You're options have become very limited, because removing the program that you installed isn't going to patch up your registry. There are more than likely some tools that will allow you mess with the registry, but you'd have to fix your computer one attribute at a time.

Reinstalling windows will automatically take over your MBR, so if you use LILO or GRUB be sure to get ready a method to reinstall them from a LiveCD. On the positive side, a reinstall/reimage isn't always bad...

Happy Hunting :-)

pixellany 01-19-2008 03:38 PM

Backup your data (you can access it from Linux) and re-install Windows.

More than once, I have tracked down an issue like this, fixed it, and then discovered more side effects which caused me to eventually re-install. Now I give it maybe 30 minutes before I grab the installation disk and make a new pot of coffee. (30 cups if it is Windows to be re-installed....;))

proc 01-19-2008 04:48 PM

As far as i know Linux can't write to NTFS without a 3rd party driver, it can only replace files that are the same size.

DJGCrusader 01-20-2008 09:49 AM

Well I suppose what you're saying is right. I'm going to start transferring important files using my iPod 30g or something. I'd like to keep my Linux partition, or at least keep most of the same settings. Is there some sort of migration manager that I can use to kepe the same settings? I know the Compiz manager built into gutsy can export settings. I'm going to remain n my state a bit longer until my lack of internet at school really ticks me off. Thanks for all your help!

theacerguy 08-14-2009 06:53 AM

well when you reinstall if he can choose to install just to the part where win was then go into a live-cd and then terminal then sudo grub
you should now have a prompt like this:
grub> at this type find /boot/grub/stage1
that will return something like hd(0,1) (/dev/sda2 which i guess it your linux part)
then root what the previous command returned so like root hd(0,1)
setup hd(0) and then wait for that to finish and reboot and you will have grub back!

pixellany 08-14-2009 08:25 AM

Please note the date of the thread and OP's closing statement implying he had a plan. (He has not been here since.)

All times are GMT -5. The time now is 09:45 AM.