-   Linux - Enterprise (
-   -   Vpn & Samba Shares (

dsimic 07-11-2006 02:39 AM

Vpn & Samba Shares

I have been trying to solve this for several days and no success. I have windows 2003 small business server (Primary Domain Controller) and several Linux Servers. I have few users using windows based VPN to remotely connect to our network. The problem is that when they connect remotely using VPN they can not connect to samba 3.0.11 shares, if they connect locally everything is OK.


redhat143 07-11-2006 09:58 AM

Recheck the permissions of the samba share.I am not sure this is a solution.

osor 07-11-2006 12:33 PM

Are you sure that WINS servers are correctly specified to the VPN clients (probably through DHCP). AFAIK, the `normal' SMB protocol uses broadcasts which don't traverse through forwarded interfaces (unless you use clever bridging), so you need to make sure the windows clients have the correct WINS info.

Other than that, we need more details to fix the problem.

dsimic 07-12-2006 01:27 AM

Dear Redhat143 & Osor thanks a lot for your quick response.
I may not have given enough details in my first post. I do not get to connect to the samba computer, so “can not see samba shares” in my post may imply that I’m able to connect. When I VPN into my SBS 2003 server all assigned ip addresses are ok the only thing that is incorrect is subnet for VPN network adapter and it is where subnet for all network adapters on the network are I do not know does this matter and I could not force different subnet mask.

When I try to map the share the following message appears.
“The network path to \\sbm_box.domain_name.local\smb_share can not be found”

I have tried to connect to the smb_share using different user option from windows. Connect as: domain_name/domain_user, pwd:domain_password and this produced different error.
“The mapped network drive could not be created because the following error has occurred. The parameter is incorrect.”

Neither of the above produces any samba log entries.

The specs for the sustems involved in the problem:
- The samba version is 3.0.11 on suse 8.2 pro. (use a file to map Win users to Lin users)
- VPN server is Small Business Server 2003
- Clients are win xp sp2

Strangely enough I have one suse8.2 box working but with samba3.0.2a and unfortunately I could not find this version of samba to install.

Could you please give me some ideas where to start with troubleshooting.

Skip-DMP 07-12-2006 08:14 AM

I assume you mean that the subnet mask is That is definitely a problem. That would mean that the entire visible network to that interface would be itself. Your samba share is running on an IP address that you can't see. How is it possible not to change the subnet mask?

dsimic 07-14-2006 01:22 AM

Dear Redhat141 Osor and Skip-DMP, thank you very much for your responses I have finally solved the problem. It was my network configuration. The problem was then DNS and WINS entries for my linux box did not exist on my Win 2003 server. So, after I added the entries using server Administrative Tools everything worked fine.

All times are GMT -5. The time now is 04:27 AM.