-   Linux - Enterprise (
-   -   Unable to mount my root filesystem !!! (

Manhatten101 08-25-2005 06:37 AM

Unable to mount my root filesystem !!!
Hello !
I recently installed, configured and networked ( DHCP) RedHat Enterprise through my VMWare image and successfully created and prepared a new partition for my Oracle 10G installation.
This was done adding in a new disk in VMWare and executing the following commands....

fdisk /dev/sdb -- and partition it as you need
mkfs /dev/sdb1
tune2fs -j /dev/sdb1
mount /dev/sdb1 /mount_point

I then updated my fstab and hey presto I now had my newfilesystem !

(Was starting to get excited here! )

I then downloaded 10G and most of the necessary packages that are required by Orace but ran into an Xserver issue which wouldn't let me open the display....
After a good deal of researching I managed to find out that it was the result of the display not being exporting properly.

Was sorted by issuing the following command.

xhost + localhost

(For some reason, DISPLAY=192.XXX.XX.X; export DISPLAY didn't work ! Also tried many other combinations but didn't work)

I then decided to transfer my oracle packages but.......what do ya know, the bloody CDROM drive wouldn't mount so tried editing my /etc/fstab............BUT ACCIDENTILY quit out of it with the 1st 2 letters of the 1st line (which unfortunatly is / slice) now, when starting up it says ....
checking root filesystem
fsck.ext3: No such file or directory BEL=/: ( U might guess by now the full word should be LABEL !!!)

And then it goes into maintenance mode. I then enter the root p/w but I cannot edit the /etc/fstab as it is in Readonly mode.....
I have tried su'ing to root and changing the permissions on the file but still cannot edit....I cant seem to get into single user mode or boot from CDROM either....... I'm getting REALLY, REALLY FRUSTRATED with this as I have put so much time into preparing it and now all my hard work seems to have gone to waste............
CAN ANYONE PLEASE HELP - Would really appreciate it.

bruno buys 08-25-2005 11:03 PM

Boot a live cd (knoppix?), mount the partition and edit the file.

Appollo 09-06-2005 02:12 PM

remount the drive in single user mode
You don't need to download Knoppix to repair this problem, simply remount the drive read/write...

mount -n -o remount,rw /

Then go in and perform necessary modifications to filesystem/files and reboot

All times are GMT -5. The time now is 07:00 PM.