-   Linux - Enterprise (
-   -   top panel missing after update (

dthaler 02-13-2013 12:40 PM

top panel missing after update
oracle linux 5.8, did an update using their package editor, which invokes yum, and after applying the update i lost the top panel from the gnome interface(applications, places, and systems). also when i click on the editor icon nothing happens. i can still use the terminal icon to open a new terminal session. i connect to the linux servers using exceed, and only when i connect as root do i have this problem, if i connect as 'oracle' everything is ok..
i ran the package editor on another of my linux servers (before i realized there was a problem) and it too has the same problem..i know what the updates were, why does it only affect the user 'root', and is there a simple solution.. i do have a set of commands that recreates the top panel, but they don't work in this case ? it's oracle linux version 5.8 64 bit

John VV 02-13-2013 02:45 PM

that sounds a bit like a bug oracle introduced to the rhel code base
-- or--
you r-clicked on the top panel and selected " remove this panel"

just r-click on the bottom panel and " new panel" and place it at the top

then click on the "new panel" and select "add to panel" and add the default gnome menu
there are TWO the " main menu"
and "menu bar" the menu bar has the "Applications" "Places" and " System"

dthaler 02-13-2013 03:42 PM

when i r-click on the bottom panel there is no 'new panel' in the list ???

John VV 02-13-2013 03:56 PM

it is there in Gnome
see screenshot below

though i am running ScientificLinux 6.3
it is the same as in RHEL 5.9

dthaler 02-13-2013 04:04 PM

in oel 5.8 right clicking on the bottom panel doesn't return the same thing,
i see create folder, create launcher..

---------- Post added 02-13-13 at 05:04 PM ----------

in oel 5.8 right clicking on the bottom panel doesn't return the same thing,
i see create folder, create launcher..
i think it's got more to do with one of the updates i did using the package editor, since i see the same results on one of my other servers that i did the same update on..

i tried the right click on one of my other servers where the top panel exists, and when i r-click on the bottom i get the window that would allow
you to create a new panel

dthaler 02-13-2013 04:46 PM

if i issue the command killall gnome-panel, the top panel is restored, but only for this session... if i disconnect and reconnedt (i'm using exceed), then the top panel is gone... i also discovered the even though the editor icon won't invoke the editor if i click on applications>>accessories >> text editor then the editor is invoked ??

so the 64000 dollar question is why doesn't the top panel stay and why doesn't the editor icon invoke the editor.... this used to work... in fact if i reconnect as the user
oracle, everything is ok ????

John VV 02-13-2013 06:27 PM

unsure , from the other servers working correctly ???
have a look at the different /var/log/yum.log's and see if there is a difference for the different servers

if not reinstall the updates

seeing as this is oracle's operating system and you do have a support contract ? right?

you might want to ask Oracle

One possible;e cause is a python error. The gnome desktop ( AND yum) use python .And it MUST be the version in the updates
if some python rpm's did not update it will break some of the gnome desktop
and "yum" will be dead

Dose this work

su -
yum update

if it says everything is up to date , then it is NOT a busted Python update

dthaler 02-14-2013 09:13 AM

no packages marked for update is the response to yum update... i created an sr with oracle, and just sent them an sosreport... i was hoping someone else might have run into a similiar problem... why would 'root' have the problem
and not the user 'oracle' ??

dthaler 02-14-2013 01:59 PM

the plot thickens.... not only does the top panel dissappear (which i can temporarily get back), not only does the editor icon do nothing, but when i do invoke the editor from application >> accessories >>text editor, i can't open up files
like the /var/log/messages or the .bash_profile, i get permission errors.. i had a vi expert on my desktop and he was able to open the .bash_profile using vi... normally when you invoke the gnome editor and go to open a file it defaults to the
root directory, when i open it now it defaults to the /home/oracle directory ??

John VV 02-14-2013 03:58 PM

and this is in the "root" account ?
but the user "oracle " "the database" ( this should NOT have a home folder) it is the database

works ?

I would reinstall

it is likely fixable but ....

dthaler 02-14-2013 05:45 PM

there is a user oracle on the server, why shouldn't it have a home folder, doesn't every user have a home folder ?

you said you would reinstall, reinstall what ??

John VV 02-14-2013 05:59 PM

that IS the database

it is like making a $HOME folder for the user "apache" on the Apache web server
the files that make up the program need to be owned by "apache"
a home folder for the "MySQL" db
you only want a user because the DB software needs to be owned by "mysql" and NO home folder is even wanted

the oracle DB needs to be owned by "oracle" and the files that make up the DB need to be owned by the user "oracle" but it dose not need a $HOME folder

dthaler 02-15-2013 07:32 AM

the other part of your answer was 'reinstall', do you mean reinstall gnome ?

John VV 02-15-2013 11:32 AM

I would just reinstall the OS

you do have a "known good backup " ? right?

if the root account is not working right

did you look at the yum logs for the other machines
and are the same for the one that is not working correctly

dthaler 02-15-2013 04:17 PM

i've been working with oracle (since it's their os), and they had me do a yum groupremove gnome, and i'm guessing that it removed more than they anticipated because in my kde environment i get a message that it can't find the kde editor.
when i try thinks like yum grouplist i get no group data available...

i backup the server to tape, could i use that tape to reinstall the os or os directories that may have been compromised ?

All times are GMT -5. The time now is 11:24 PM.