-   Linux - Enterprise (
-   -   syslinux error when usb booting Scientific linux 6.0 LiveDVD (

possum 04-03-2011 04:05 PM

syslinux error when usb booting Scientific linux 6.0 LiveDVD

I'm having some trouble getting the Scientific Linux 6.0 LiveDVD to boot from a USB drive. The error I am seeing is:


vesamenu.c32 : not a com32r image
I tried using the latest Fedora USB creator which give the above error. Pressing the tab key then lists the possible boot choices, but selecting any of them results in another error:


no root device found
So then I tried the utility from pendrive linux. Scientific linux is not listed, so I tried selecting the last option (new syslinux) and the results are the same (incuding the problem finding the root device). If I choose the old syslinux, I still get the vesamenu.c32 error. However, if I press tab I can select a boot option and it finally boots.

The issue sounds like a syslinux version compatability issue, but I am unsure how to determine which version is required.

possum 04-03-2011 05:10 PM

eh...I figured it out.

1) Booted up liveDVD
2) From the liveDVD, I copied the entire /usr/share/syslinux directory to a spare flashdrive.
3) Booted back into Windows XP.
4) From the saved syslinux directory, copied vesamenu.c32 to the /syslinux folder of my LiveDVD flashdrive (my G: drive)
5) Reinstalled the syslinux bootloader to the liveDVD flashdrive (from the saved syslinux directory).

syslinux.exe -maf -d /syslinux g:
6) (optional) - Delete the unused /boot and /EFI folders from the LiveDVD flashdrive.

Now it's working. While I don't know what version Scientfic linux requires, I can say the version found on the LiveDVD works.

All times are GMT -5. The time now is 05:39 PM.