LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (https://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   SAN LUN device order (https://www.linuxquestions.org/questions/linux-enterprise-47/san-lun-device-order-210776/)

jhumeston 07-28-2004 06:43 PM

SAN LUN device order
 
I have a RHL EN3.0 server attached to my SAN via 2 Emulex HBAs. When I loaded the drivers for the HBAs, it discovered the LUN (LUN 19) and mapped it to /dev/sda. The problem is that my local disk used to be /dev/sda1-4. I want to make sure that the local disk stays /dev/sda so when I add new SAN disks, they dont change things. A good example is that every time I boot the system I get errors trying to mount the swap on /dev/sda3.

in /etc/modules.conf I have the Emulex drivers listed after the local SCSI drivers, but they for some reason still get loaded first.
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih
alias scsi_hostadapter lpfcdd

in /var/log/messages I notice that the following are being mapped:

SCSI0 = Emulex 0
SCSI1 = Emulex 1
SCSI2 = IBM local SCSI
SCSI3 = IBM local SCSI

any ideas on how to make the local SCSI drivers load first? i.e SCSI0 = IBM local SCSI?

thanks

greyhoundz1718 07-28-2004 08:25 PM

Hi,

Arrange properly the modules.conf then rebuild your initial ramdisk. This should fix this.

:)

jhumeston 07-28-2004 08:29 PM

I have the lpfcdd module last, and that is the Emulex driver. How else can I arange it?

jhumeston 07-29-2004 08:24 PM

Solution:
in /etc/modules.conf
name the alias items so they will load in that order

alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih
alias scsi_hostadapter2 lpfcdd

I just added the 2 to the lpfcdd driver alias name and that solved it.


All times are GMT -5. The time now is 02:48 PM.