LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 03-07-2007, 04:08 AM   #1
stvy
LQ Newbie
 
Registered: Mar 2007
Posts: 17

Rep: Reputation: 0
QLA2462 dual port 4Gb/s FC HBA, Red Hat EL 4 update 4 hardware false detect


Hi,

I am using a QLA2462 dual port 4Gb/s FC HBA with the latest driver from the QLogic website for Red Hat Eneterprise Linux 4 64 bit edition update 4.

Upon booting the system detects the QLA2462 as a 23## series card. The system loads the built in default 23## series drivers. These leaves the HBA unuseable, I cannot connect to it in SAN surfer nor can it detect any devices connected to it.

My solution is to edit the /etc/rc.local file and unload the 23## series driver and then load the correct driver using the "modprobe" command.

The HBA then works fine.

I consider this to be somewhat short of an elegant solution.

What I would like to do is find out at what stage the incorrect driver is being loaded and stop it then, and then load the correct driver.

At the moment I am not booting from the SAN that I am connecting to but I may wish to do so in the future. I assume that I would need to fix this before I could do that.

Could someone please give me some advice about how to stop the kernel loading this incorrect driver and to force it to load the correct driver early enough in the startup process so that I can access the filesystems onboard the SAN connected to the QLA2462?


I have been told that there was a bugzilla about this when update 4 came out and that hwdata-0.146.23.EL-1 addresses it.

The following is the contents of the modprobe.conf file:

alias eth0 tg3
alias eth1 tg3
alias scsi_hostadapter1 ips
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias scsi_hostadapter2 aic79xx
#install qla2xxx /sbin/modprobe qla2xxx_conf; /sbin/modprobe --ignore-install qla2xxx
#remove qla2xxx /sbin/modprobe -r --first-time --ignore-remove qla2xxx && { /sbin/modprobe -r --ignore-remove qla2xxx_conf; }
#alias scsi_hostadapter3 qla2xxx_conf ql2xfailover=0

The 3 entries that are commented out were put in by the Qlogic driver automatically.

The following is the contents of the /etc/rc.local file:

#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

modprobe -r qla2322
modprobe -v qla2400

touch /var/lock/subsys/local


As you can see I am unloading the 2322 driver and loading the correct.

The system will load the qla2xxx and qla2400 drivers. I am not 100% but think the 2xxx drivers is the driver which you pass configuration settings such as failover control etc to.

Any suggestions how I can modify my system to fix this problem?

Thanks,

Steve
 
Old 03-21-2007, 05:36 PM   #2
admiyo
LQ Newbie
 
Registered: Dec 2006
Location: SF Bay Area
Distribution: RHEL[3|4], Debian, CentOS
Posts: 15

Rep: Reputation: 0
Hotplug blacklist

You might try putting them in the hotplug blacklist. That will prevent udev from finding them and loading the wrong drivers. You can then load the correct driver at a later point. We do this to deal with infninband HCAs. However, the network up scripts might also cause the wrong driver to be loaded.
 
Old 03-22-2007, 09:45 AM   #3
stvy
LQ Newbie
 
Registered: Mar 2007
Posts: 17

Original Poster
Rep: Reputation: 0
Hi,

The problem is now solved. The solution was indeed to incorporate the hotplug blacklist:

The solutions was;

1. upgrade the hwdata rpm. There is a bugzilla on this and the QL2462 is incorrectly defined in the pci device table. hwdata-0.146.23.EL-1 fixes this.
2. insert the 3 alias scsi_hostadapter lines into the /etc/modprbe.conf

alias scsi_hostadapter1 qla2xxx_conf
options ##### the options required by the particular config you want ####
alias scsi_hostadapter2 qla2xxx
alias scsi_hostadapter3 qla2400

3. Blacklist the qla2300 driver in /etc/hotplug/blacklist
4. rebuild the RAMDISK using mkinitrd

The driver is then loaded automatically at boot and I can mount a filesystem from the SAN automatically via an entry in /etc/fstab as I need to.

Cheers,

Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat Update Agent freezing, unable to update (FC4) Malakye Fedora 1 12-09-2005 09:02 PM
red hat won't detect pcmcia card sparkac Linux - Newbie 7 11-16-2003 06:00 PM
Red Hat doesnt detect my NIC OrganicX Linux - Networking 18 03-24-2003 02:40 PM
Red Hat 6.0 Can't detect filesystem to install on mkoukoullis Linux - Software 1 05-16-2001 08:58 PM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 05:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration