LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (https://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   ps2pdf (https://www.linuxquestions.org/questions/linux-enterprise-47/ps2pdf-493535/)

yar110 10-18-2006 11:04 AM

ps2pdf
 
Hi All,

I have red hat 4 AS with ps2pdf version 7.07.
when i try to convert ps to pdf with "ps2pdf" like:

ps2pdf file newfile

i recieve the following error:
GNU Ghostscript 7.07: Unrecoverable error, exit code 1

the problem is that it seams like the new version 8x not
fit to red hat 4, i can't find RPM for red hat 4.

any idea???
Do you think the upgrade could solve it or its another problem?

Thanks.

billymayday 10-18-2006 03:21 PM

Are you sure that there isn't something wrong with the postscript file?

If you can't find ans rpm, you can always build from source.

Is ps2pdf part of the ghostsctipt package?

yar110 10-19-2006 02:30 AM

ps2pdf
 
Yes i am sure, this is the same for any file.

billymayday 10-19-2006 04:10 AM

Weird. Have you tried removing it and reinstalling?

yar110 10-22-2006 01:55 AM

ps2pdf
 
Yes, this was solve part of the problem.
on all of the 3 servers i have Oracle, the Oracle
is create PS files with version 7.0.7.

when i try to ps2pdf i receive the error that i mention earlier.

i try to copy PS files from windows(create with version 8.14)
for this file the ps2pdf finish successfully.

If the problem is the version so i don't know what to do
since i don't find newer version to red hat 4.

btw, this problem occur for all three servers.

Thanks.

billymayday 10-22-2006 04:19 AM

Sounds like either oracle is the problem, or the ps printer oracle is using doesn't create the correct file. Try another printer driver. This may help

yar110 10-22-2006 07:07 AM

Update
 
Hi,
I have some update regarding this issue.

i was upgrade the ghostscript to 8.14.
now i recieve othe error:


Unrecoverable error: invalidfileaccess in file
Operand stack:
false Unicode Decoding Unicode Unicode --nostringval-- /usr/share/ghostscript/8.14/Resource/Decoding/Unicode r


btw, i note that just some of the files fail and other success.
in the original the operating system was upgrade from 2.1 to 4.
could be the the older files fail(don't sure yet)

any idea???

Thanks!!!!!!!!!!!!


All times are GMT -5. The time now is 03:35 AM.