-   Linux - Enterprise (
-   -   PHP5 on Apache saving .php files (

Skip-DMP 08-02-2006 03:58 PM

PHP5 on Apache saving .php files
I've been working for weeks to get the right configuration and was beating my brains in to get the httpd.conf file to stop reporting errors when upgrading from PHP4 (4.4.2) to PHP5 (5.1.4). Finally I found a good resource and successfully can stop and start the server with the PHP 5 configuration in place.

And now nothing which runs php works at all. Instead of loading up the expected pages, I am prompted to save the .php file (Firefox) and on a Windows machine in IE it simply loads a "Page cannot be displayed" message.

Here are the notable lines from my httpd.conf file regarding php:


LoadModule php5_module /usr/lib/httpd/modules/
AddHandler php5-script php
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
AddType text/html .php
Yes, the httpd.conf file is the correct one.

I've seen the .phps line written with or without the "." and I have tried both ways.

I have seen this noed on a couple of other posts here and there with possible resolutions? Not really sure or if the issue was simply dropped.

isuck@linux 08-03-2006 08:56 AM

I run php5 with no problems, try ### all the lines but this

LoadModule php5_module /usr/lib/httpd/modules/

and restart apache. Should work. By the way I assume is in the correct folder.

Skip-DMP 08-03-2006 09:25 AM

For the couple months I have been fighting these issues, you bet...

I upgraded my version of apache to 2.2.3 and it appears to be working now. Evidently there are some issues (notably unpublished issues) with 2.0.46. Now I just have to rectify a MySQL issue with connectivity to my database.

All times are GMT -5. The time now is 06:44 PM.