LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (https://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   NTP time sync with windows 2000 AD time (https://www.linuxquestions.org/questions/linux-enterprise-47/ntp-time-sync-with-windows-2000-ad-time-546391/)

csghosh 04-16-2007 01:18 AM

NTP time sync with windows 2000 AD time
 
I have 5 servers running on RHEL 4 update 4, namely L2, L6, L15, L16 and L18. All the servers are running in NTP for time synchronization. L6, L15, L16 and L18 are synchronizing time from L2. There is no issue in it.

But my requirement is to synchronize time of L2 with windows 2000 AD Time running on U1 server, which is synchronized with some NTP Server. An NTP service is running on U1. In the ntp.conf of L2 has been directed to sync time from U1 but it is always sync to local.
[root@l2 ~]# ntpq -p
remote refid st t when poll reach delay offset jitter
===============================================================
u1.xxxad.com 0.0.0.0 2 u 51 64 0 0.000 0.000 4000.00
*LOCAL(0) LOCAL(0) 3 l 50 64 37 0.000 0.000 0.004

Now, What I like know is how to synchronize with Windows 2000 AD time? What changes required in ntp.conf in L2, if any, or what are the parameters or services needs to be checked in U1 so that it can sync L2?


my ntp.conf as follows:

restrict default nomodify notrap noquery
restrict 127.0.0.1
# - CLIENT NETWORK -------
#restrict 192.168.1.0 mask 255.255.255.0 notrust nomodify notrap
# --- OUR TIMESERVERS -----
#server 0.pool.ntp.org iburst
#server 1.pool.ntp.org iburst
#server 2.pool.ntp.org iburst
server u1.xxxad.com.sg iburst
server 127.127.1.0
# --- NTP MULTICASTCLIENT ---
# --- GENERAL CONFIGURATION ---
# Undisciplined Local Clock.
fudge 127.127.1.0 stratum 3
# Drift file.
driftfile /var/lib/ntp/drift
broadcastdelay 0.004
# Keys file.
keys /etc/ntp/keys

Please donít hesitate if you require further clarification. Thanking you in advance.

stress_junkie 04-17-2007 10:54 AM

I think the problem is that the Windows machine may be synchronizing but it isn't running the NTP server service. If it were running NTP server service then you would just be able to point the NTP client on Linux to that Windows machine. If that isn't working then I think that the Windows machine needs to be configured as an NTP server.

http://support.microsoft.com

Or maybe the Linux box needs to be a member of the AD. That would probably require the use of Samba on the Linux box.

slacky 04-17-2007 01:18 PM

IIRC, Windows Time Service might only be a SNTP server, and not a full NTP server. There's no problem for a SNTP client to sync time with a NTP server, but I'm not sure if its possible for an NTP client to sync time with a SNTP server.

csghosh 04-18-2007 03:33 AM

Thank you for a quick reply.

I am providing some more details that may help you.
SNTP service running on windows2000.
The nmap -sU on u1 server output is as follows:
123/udp open|filtered ntp

but the ntptrace output as follows
[root@l2 ~]# ntptrace u1.xxxad.com.sg
u1.xxxad.com.sg: timed out, nothing received
***Request timed out

All the servers in same domain i.e., xxxad.com.sg

What are the alternative to time sync with ADtime.

Dox Systems - Brian 04-18-2007 08:13 AM

When I was stuck with AD in addition to Unix boxes I would just sync them to the same source...

csghosh 04-19-2007 07:24 AM

Thanks for your suggestion. But unfortunately I dont want to sync to the same source. Also I feel that there is no other solution available.

csghosh 04-24-2007 02:10 AM

Hey guys,

I have got the solution and support from RedHat and it really worked out the way I just require. I have just used the net TIME SET command. This is just share with all of you.

Thanks you all.

austin001 02-24-2012 03:46 PM

FYI for late readers
 
net time set -I ipaddressofyouradserver

works quite nicely for me. I have a phone system purposely VLANed out of being able to contact NTP servers on the internet. The CEO complains that the time on the phone system (CENTOS) is off by minutes. Routing is set up so that it can communicate to the other subnet. This fix worked great.


All times are GMT -5. The time now is 06:04 AM.