-   Linux - Enterprise (
-   -   nedit - problems (

rustyray 04-07-2008 07:42 PM

nedit - problems
Ok we all know that nedit is not the best editor but I have a client that uses it and I cannot get it to work with ssh2.
I get the error " cannot open display"
I have tried the following (using tcsh)
setenv DISPLAY=<hostname>:0.0
nedit -d <hostname>:0.0
I have set the xhost + so all clients can access that system (tmp setting reset after failure)
Any ideas ?
BTW this is only happening on 1 of the 6 systems we have.
We are using RH Enterprise 4.X AS.

networkr 04-07-2008 09:13 PM

Nedit over SSH
I do this all the time with Cygwin on an XP machine.

Things to ensure are that X is running on the local machine. X is not part of Windows, so I use the Cygwin/X package. To do that from WinXP/Cygwin, I do this:

"startxwin.bat" from a bash shell in Cygwin.

I get this....

$ startxwin.bat
startxwin.bat - Starting on Windows NT/2000/XP/2003

Then an xterm also launches where I can do the following:

From the machine I'm sitting in front of (WinXP box) I do this in the xterm:

at Cygwin xterm prompt, type "xhost +" (to enable all hosts XDMCP)
ssh to Linux machine I want to run the X application from
at Linux prompt, type "export DISPLAY=<hostname>:0.0"
then I can just type "nedit" and nedit will come up.

P.S. All the stuff from the xterm onward also works from a Unix or other Linux client in whatever X Terminal program you're using (Gnome Terminal or Konsole), exact same syntax. Also, any program that runs in the windowing environment that you can launch from the command line are also candidates for the same type of use.

rustyray 04-08-2008 01:45 PM

Nedit over SSH
First let me say thank you for the reply, but I tried what you suggested and I still cannot get it to work. I think I should add that we are trying this server to server and the other 5 systems (RHL Enterprise 4.X server)do not have this issue.
I have matched the settings on the problem child that the other systems have, but it still does not want to pop up the nedit window on the system I am connected from.
If I go to one of the other systems or even the problem system and ssh to one of the other systems it will work, but only when I ssh to that 1 system will it not work.
I even tried emacs and it gives me that error "set xhost + X.X.X.X or try setenv DISPLAY=hostname:0.0.
None of this works.. I am beginning to think I may have to reinstall the nedit software or even reinstall RHL on that system (which is not a good answer either). If you come up with some more ideas let me know I am willing to try almost anything at this point.

networkr 04-08-2008 02:13 PM

The only other things I can think of is that your XDMCP is not enabled on that one RHEL machine or there's a firewall up, but there are a number of things to check outlined in various faqs and howtos... Here's a few links fyi. Happy reading.

rustyray 04-09-2008 03:45 PM

Thanks. Looks like I have a lot of reading in front of me...

All times are GMT -5. The time now is 10:53 PM.