LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 01-10-2015, 02:15 PM   #1
ApacheOmega
Member
 
Registered: Jan 2015
Location: Planet X aka Planet 10 (I swoop down every 3600 years)
Distribution: Fedora21
Posts: 36

Rep: Reputation: Disabled
Installing Red Hat Enterprise Linux 7 Server with GUI


Hello!
I just installed RHEL 7 on my VmWare 11 Virtual Machine and for some reason I'm only able to see the command line. how do I install the GUI portion from the command line or am I just asking the dumbest newbie question ever?

Thank You
AO!
 
Old 01-10-2015, 02:29 PM   #2
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_12{.0|.1}
Posts: 5,583
Blog Entries: 11

Rep: Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599Reputation: 3599
First, I don't think the "server" edition includes the GUI... it is the server edition after all!

Second, RHEL is not a free Linux but requires a subscription. If you are paying the subscription you should probably be using the Red Hat support and resources as your primary information source.

If you are not paying the subscription you should not use it, but instead use CentOS which is free and is 99+% identical to RHEL. That will not only make it easier for those here to answer your future questions, but it will also allow you to install updates and access to other software repos - and will spare you the constant reminders that you should not use RHEL without the subscription!

And welcome to LQ!
 
Old 01-10-2015, 05:00 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
the NOT FREE RHEL7.0 that you DID buy
dose NOT instal la gui by default

the reason :

SERVERS normally DO NOT have a gui
nor is one normally wanted!
they are a big and MAJOR security risk and HOLE just waiting to happen

so for a SERVER install you did buy the 1 year standard contract for $799 USD per year


if not

do not use redhat -- you HAVE TO pay for it

instead install the FREE rebuild
CentOS 7.0

now

cent WILL install a gui if you select the DESKTOP install
 
Old 05-16-2015, 11:43 AM   #4
Terrible-tony
LQ Newbie
 
Registered: May 2015
Posts: 2

Rep: Reputation: Disabled
Hi,

Googling led me here, so I've just registered and felt I should contribute because I maybe the bigger newbie than ApacheOmega. I'm in the same boat, I've got a developer version of RHEL 7.1 (a non-refundable $99 for a year's subscription) which I've installed on vbox on my laptop. I wanted it to run EAP 6.4.0 so I can investigate/evaluate jboss's BRMS and BPM suites (which is executed through jboss's eclispe-based dev studio).

Apart from confirming the expression 'a fool and his money' I'm interested in being able to have a look at the BRMS and BPM suite, this needs the jboss Enterprise Application Platform (EAP) 6.4.0 and this only runs on windows servers or RHEL (and some other O/S).

Could I expect to install EAP on CentOS and for it work as normal? I tried EAP on my windows 8.1 laptop and it worked ok then I got an error which I thought might be from using EAP in a non-recommended O/S (adding users in the EAP just not being recognised).

The other option is to connect to EAP on vbox from developer studio on my laptop but as a non-techie trying to understand all this, the learning curve maybe pushing me too close to breaking point!

Thanks
 
Old 05-16-2015, 01:30 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
the very FIRST thing is check if your laptop is compatible
https://access.redhat.com/documentat...ility-x86.html

being a SERVER os it might NOT support the hardware in a laptop

then see the install guide
https://access.redhat.com/documentat...ide/index.html

at time of install you can select the DESKTOP install
https://access.redhat.com/documentat...-mode-x86.html

if not and you later install Gnome3

if you need a desktop on RHEL you can install gnome3 on RHEL7
BUT you will NEED a 3d card ( the laptop "chip" ??? might be usable ??? )
Code:
su -
yum grouplist
in that output should be the default desktop or gnome

Code:
su -
yum groupinstall "X Window System" Desktop
then
Quote:
Run the following command to edit the /etc/inittab file:
Code:
    vi /etc/inittab
Press the I key to enter insert mode.
Find the line that includes the text initdefault. Change the numeral 3 to 5.
Type :wq and press the Enter key to save the file and exit the vi text editor.

Reboot the system using the reboot command. Your system will restart and present a graphical login.
 
1 members found this post helpful.
Old 05-17-2015, 05:31 AM   #6
Terrible-tony
LQ Newbie
 
Registered: May 2015
Posts: 2

Rep: Reputation: Disabled
Thanks John,

I tried the steps you suggested and I was able to able to install X windows, however for the last step the inittab file had the comments to execute the systemctl command to a graphical target and then reboot, but this didn't work.

I don't know where to start with that but having slept on it I'm coming round to the idea of having jboss developer studio on my laptop connecting to EAP on RHEL on virtualbox, as per comments below I can't see the reason to have a GUI on a server.

I think that I just need to mess about with the bridged adapter on vbox so that the EAP server is recognised in dev. studio as just being across a network connection, it sounds like the most sensible set-up even though it's just me messing about.

Thanks again.
 
Old 05-17-2015, 09:08 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
oops
mixing 6 with 7

see the like in the documentation
7.3.4. No Graphical User Interface Present
https://access.redhat.com/documentat...ml#idp27230240

the link
" https://access.redhat.com/solutions/5238"
the above requires that you have a valid license and registered on the redhat site
-- you have to log in to the redhat site to use that link


and section
12.1.1. Problems with Booting into the Graphical Installation
https://access.redhat.com/documentat...ml#idp13888272
 
Old 06-07-2015, 06:50 PM   #8
manoj_hanse
Member
 
Registered: Mar 2008
Posts: 48

Rep: Reputation: 1
Hello Mr. ApacheOmega.

Sometimes the problem is too simple. VMware by default when detects a OS like RHEL6/7 in DVD / usb drive installs it using simple/quick setup mode. This results in installation choosing Default package list (minimum) in this case. so after installation the control goes to command line. (or init level 3). so set up GUI mode which is not installed you have to install it from Repo or DVD. using yum. So to do this create a repo first:
1)vim /etc/yum.repos.d/DVD.repo
2)put this in file:
[DVD]
name=fromISO
baseurl=file:///path_of_DVD_or_Usb_drive .............eg:- file:///mnt/iso
enabled=1
gpgcheck=0

save this file.

if theres any other repo file in this path, edit it by changing enabled=1 to 0.

in case you have a active RHN subscription and have already registered with Red Hat no need to create repo file.

now run this command:

yum clean all

yum groupinstall "X Window System" -y

then

systemctl set-default graphical.target

systemctl set-default multi-user.target

restart the system.
 
Old 06-10-2015, 08:42 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by manoj_hanse View Post
Hello Mr. ApacheOmega.

Sometimes the problem is too simple. VMware by default when detects a OS like RHEL6/7 in DVD / usb drive installs it using simple/quick setup mode. This results in installation choosing Default package list (minimum) in this case. so after installation the control goes to command line. (or init level 3). so set up GUI mode which is not installed you have to install it from Repo or DVD. using yum. So to do this create a repo first:
1)vim /etc/yum.repos.d/DVD.repo
2)put this in file:
[DVD]
name=fromISO
baseurl=file:///path_of_DVD_or_Usb_drive .............eg:- file:///mnt/iso
enabled=1
gpgcheck=0

save this file.
..which will make any subsequent updates fail, if the DVD is not present, since the 'repo' file can't be read. And it has nothing to do with VMWare and a 'default' installation...RHEL 7 (as the OP said they were using), DOES NOT INSTALL a GUI unless you SPECIFICALLY tell it to. They didn't.
Quote:
if theres any other repo file in this path, edit it by changing enabled=1 to 0.
...which will further cause you problems later, since you won't get ANY updates/patches, nor be able to install from those repos.
Quote:
in case you have a active RHN subscription and have already registered with Red Hat no need to create repo file.
..and if you DON'T have an active RHN subscription, then WHY would you bother using it??? All you'll wind up with is an unstable, unpatched system. Load CentOS instead if you're not going to pay.
Quote:
now run this command:

yum clean all
yum groupinstall "X Window System" -y

then

systemctl set-default graphical.target
systemctl set-default multi-user.target
restart the system.
...and those commands were given above, and in the documentation links.
 
Old 10-03-2015, 05:59 AM   #10
new2linuxsyn
LQ Newbie
 
Registered: Jan 2011
Location: UK
Distribution: Red Hat Enterprise Linux
Posts: 2

Rep: Reputation: 0
Hi guys,

I have also just started series of Red Hat 7 linux tutorials (www.shahid-academy.com). My first tutorial is about installation of Red Hat enterprise Linux 7. Please visit my site and suggestions are highly appreciated to improve contents and remove mistakes if found any

Thanks and regards

Shahid
 
Old 10-03-2015, 03:29 PM   #11
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by new2linuxsyn View Post
Hi guys,
I have also just started series of Red Hat 7 linux tutorials (www.shahid-academy.com). My first tutorial is about installation of Red Hat enterprise Linux 7. Please visit my site and suggestions are highly appreciated to improve contents and remove mistakes if found any
Since you've been here for FOUR YEARS, you should know that advertising isn't permitted. Posting your blog and asking people to visit it IS advertising...we aren't going to help you publicize your 'training academy'. And if you can't spot the errors in your 'tutorials', then you shouldn't be posting them.
 
Old 10-03-2015, 05:54 PM   #12
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
at this point "new2linuxsyn" is SPAMing
see the other post ADVERTISING this very questionable "site"
there are only 2 posts on that site one from aug9 and the second from Aug 22
-- nothing NEW
but there is one rather NASTY bit of tracking software trying to set a tracking cookie


http://www.linuxquestions.org/questi...9/#post5429342
 
Old 10-05-2015, 12:28 PM   #13
Ryanms3030
Member
 
Registered: Jan 2014
Distribution: Debian, Mint, CentOS, Ubuntu
Posts: 261

Rep: Reputation: Disabled
Is the installer for RHEL 7 different from Centos 7? Centos 7 install Base Enviorments has "Server with GUI" as an option. I mainly ask because I'm reading Sander Van Vugt's RHCE/RHCSA 7 Cert Guide and that is the recommended install for the exams and he also implies that those options (and almost everything else) in Centos 7 are identical to RHEL 7
 
Old 10-05-2015, 01:47 PM   #14
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
Ryanms3030

pop in the install dvd and LOOK !
 
Old 10-07-2015, 03:24 PM   #15
Ryanms3030
Member
 
Registered: Jan 2014
Distribution: Debian, Mint, CentOS, Ubuntu
Posts: 261

Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
Ryanms3030

pop in the install dvd and LOOK !
Thanks. I downloaded and installed the iso and yes 'server with gui" is one of the default options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing openoffice 3.4 on red hat enterprise linux 5 (tikanga)server bumshotz Linux - Software 3 06-22-2012 08:30 AM
Installing Red Hat 4 enterprise server on core 2 duo machine hadimunar Red Hat 5 05-25-2009 12:49 AM
Red Hat Enterprise Linux AS v4 without GUI ? (forced KDE) Vilius Red Hat 7 05-16-2008 04:36 PM
Installing Red Hat Enterprise Linux AS 4 oneders Linux - Newbie 1 02-01-2007 08:36 AM
Installing DB2 v.7.2 on Red Hat Enterprise Linux 3 agentjfp Linux - Software 2 06-04-2004 05:26 AM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration