LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 10-21-2008, 04:54 AM   #1
eforest
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
How to load all drivers for uninstalled hardware with RHEL 4


Hello,

We are currently trying to backup RHEL 4 servers running on old hadrware (IBM HS20 with SCSI disks), to be restored on newer hardware (IBM HS21 with SAS disks).

To achieve this, we would need to load in the HS20 images, prior to backup, the drivers of the HS21 hardware, so that the restore succeeds.

Since we have several dozens of servers to backup in our lab, we are looking for a rather time efficient method.

Is there any way to load "automatically" the HS21 drivers (for instance the ons os SAS HDD) on teh HS20 image?

Thanks in advance for your help, Eric

Last edited by eforest; 10-21-2008 at 05:05 AM.
 
Old 10-21-2008, 10:17 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Virginia, USA
Distribution: Debian 12
Posts: 8,336

Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
I suggest that you create a second kernel on the HS20 drive. Then create a initrd for the second kernel which loads the HS21 modules instead of the HS20 modules. Change grub to dual boot the two kernels. Then you can boot the kernel for the drive type for whichever drive type you happen to be using.

---------------------------
Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Restricted Nvidia drivers not listed in Hardware Drivers (8.04 Hardy Heron, liveCD) shroomy_bee Ubuntu 4 07-06-2008 10:16 AM
Hardware Drivers not detecting hardware correctly in Hardy adanedhel728 Ubuntu 2 04-26-2008 03:22 AM
Uninstalled Firestarter, but Red Hat still trying to load it during boot cosaides Linux - Software 2 01-22-2008 04:50 PM
RHEL load with SCSI drives - NO DRIVERS rwo_linux Red Hat 3 01-12-2005 06:27 PM
Uninstalled udev and now my video drivers don't work... Shafted Debian 1 07-01-2004 03:01 PM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 04:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration