-   Linux - Enterprise (
-   -   How to install libcgroup package on centos 5.5? (

Kaustuv 07-04-2013 08:49 AM

How to install libcgroup package on centos 5.5?
Hi All,

I have tried to install the libcgroup package using YUM with following command on 32 bit centOS 5.5:
>yum install libcgroup

I have got following error:
No package libcgroup available.

The file /et/yum.repo.d/CentOS-Base.repo is already have entires for

I have following queries?
1) Does 32 bit centOS 5.5 support cgroup?
2) Do I need to add other repositories on .repo file to install libcgroup package?


Linux MR 07-04-2013 10:19 AM

I think you are going to need a newer kernel

Red Hat Enterprise Linux 6 provides a new kernel feature: control groups, which are called by their shorter name cgroups in this guide.

but then again you can always search your repos (see if it is in EPEL-type repo)

# yum search cgroup
# yum search control group
Hope that helps

knudfl 07-04-2013 10:44 AM

No libcgroup in any repo, AFAIK.

'libcgroup-0.33' will build on CentOS 5.x (The "el6 version", libcgroup-0.37 failed)

# yum install pam-devel byacc


$ rpmbuild -bb libcgroup.spec
Wrote: /home/knudfl/rpms/RPMS/i386/libcgroup-0.33-3.el5.i386.rpm

Kaustuv 07-04-2013 11:41 AM


On which version of kernel on centOS U build libcgroup? Is it on minimum 2.6.24 kernel? I have read somewhere that cgroups work only kernel versio>=2.6.24. Is it right? Or itsit
it can be used on lower version also?


knudfl 07-04-2013 12:12 PM

# 4 .

On which version of kernel on centOS U build libcgroup ?
→ 2.6.18 .
But : No kernel files seem to be required for building libcgroup.

Description : ( from the above mentioned Fedora 11 source )
Control groups infrastructure. The tools and library help manipulate, control,
administrate and monitor control groups and the associated controllers.



Kaustuv 07-06-2013 11:11 AM

Hi knudfl,

I have build the rpm of libcgroup from source rpm & installed both libcgroup & libcgroup-devel.But when I tried to mount a cgroup it throws following error:

# mount -t cgroup -o cpuset red /cgroup/red
mount: unknown filesystem type 'cgroup'

My machine is on 2.6.18 kernel booted.
The mount command isn't suporting the Type=cgroup. Anything more I need to do?


knudfl 07-06-2013 11:30 AM

# 6 .

Ref. your post #4 :
""I have read somewhere that cgroups work only kernel version>=2.6.24.""

I guess it means that "groupfs" could be in "kernel-2.6.24 or later" only ?

'libcgroup' is to be used when 'groupfs' ("group file system") is included in the kernel.
And when you actually have a setup with groupfs / groups.


All times are GMT -5. The time now is 12:16 AM.