LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 08-15-2007, 10:32 AM   #1
potatoque
LQ Newbie
 
Registered: Mar 2006
Posts: 27

Rep: Reputation: 15
Question how set an environment variable in RHEL4


my binary for my lotus domino is on /opt/ibm/lotus/bin

When everytime i run fixpack installer i got this error

You must create the environment variable NUI_NOTESDIR as path of the directory that contains notes/latest. E.g., for the default path /opt/lotus/notes/latest NUI_NOTESDIR=/opt/lotus
export NUI_NOTESDIR

How would i set the environment variable ?
 
Old 08-15-2007, 10:42 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
That error message tells you how to do it if you're using Bash (or Bash-compatible shells, I think Korn shell is one such shell):

NUI_NOTESDIR=/opt/lotus
export NUI_NOTESDIR

You can put these lines in your ~/.bashrc.

Are you using a different shell?
 
Old 08-16-2007, 12:39 AM   #3
potatoque
LQ Newbie
 
Registered: Mar 2006
Posts: 27

Original Poster
Rep: Reputation: 15
im using bash

im using bash shell. can you teach me how to do it ?

im a bit confused.
 
Old 08-16-2007, 02:19 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
What don't you understand?

Edit: either do it as above or combine both lines into one like so:

export NUI_NOTESDIR=/opt/lotus

and add to your ~/.bashrc. Obviously if the directory is different for your installation, set it accordingly.

Last edited by Nylex; 08-16-2007 at 02:22 AM.
 
Old 08-16-2007, 05:57 AM   #5
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
You could try,
$ NUI_NOTESDIR=/opt/ibm/lotus/bin lotus Or same thing but with an env in front. Seeing as how it's an environment variable that's not going to bugger anything, as would LANG or TERM sometimes you might as well put it in .bashrc or whatever.
 
Old 08-29-2007, 10:07 AM   #6
potatoque
LQ Newbie
 
Registered: Mar 2006
Posts: 27

Original Poster
Rep: Reputation: 15
ok i got it now

made it run thanks guys..
 
Old 07-21-2008, 06:23 AM   #7
jaseka
LQ Newbie
 
Registered: Oct 2007
Posts: 15

Rep: Reputation: 0
How about adding these lines ( export ...) in /etc/profile file in RHEL4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set environment variable yuan13452 Linux - Software 7 09-03-2007 05:23 PM
can't set environment variable baosheng Linux - Software 3 04-03-2007 01:53 AM
How to set a value of environment variable? ukrainet Linux - Newbie 1 12-28-2004 04:33 AM
Set Environment Variable lloyd_stevens Linux - Software 1 07-30-2003 12:38 PM
how do you set the environment variable CC? mr.moto Linux - General 0 12-17-2001 09:17 PM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration