LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 05-28-2008, 09:35 PM   #1
msthing
LQ Newbie
 
Registered: May 2008
Posts: 6

Rep: Reputation: 0
Smile Don't work tftp server


Im hoping you guys can help me. Here is a description of what I have going on.

My tftp server is not working on RHEL5 and the log message in
"/var/log/message" file reads like following. --> in.tftpd[2893]: cannot bind to local socket: Permission denied

May 28 18:40:08 faoserver xinetd[2885]: START: tftp pid=2893 from=10.10.10.1
May 28 18:40:08 faoserver in.tftpd[2893]: cannot bind to local socket: Permission denied
May 28 18:40:08 faoserver xinetd[2885]: EXIT: tftp status=71 pid=2893 duration=0(sec)
May 28 18:40:08 faoserver rpc.statd[1931]: recv_rply: can't decode RPC message!
May 28 18:40:09 faoserver rpc.statd[1931]: recv_rply: can't decode RPC message!
May 28 18:40:10 faoserver xinetd[2885]: START: tftp pid=2894 from=10.10.10.1
May 28 18:40:10 faoserver in.tftpd[2894]: cannot bind to local socket: Permission denied
May 28 18:40:10 faoserver xinetd[2885]: EXIT: tftp status=71 pid=2894 duration=0(sec)
May 28 18:40:10 faoserver xinetd[2885]: START: tftp pid=2895 from=10.10.10.1
May 28 18:40:10 faoserver in.tftpd[2895]: cannot bind to local socket: Permission denied
May 28 18:40:10 faoserver xinetd[2885]: EXIT: tftp status=71 pid=2895 duration=0(sec)
May 28 18:40:11 faoserver in.tftpd[2896]: cannot bind to local socket: Permission denied
May 28 18:40:11 faoserver xinetd[2885]: START: tftp pid=2896 from=10.10.10.1
May 28 18:40:11 faoserver xinetd[2885]: EXIT: tftp status=71 pid=2896 duration=0(sec)
May 28 18:40:13 faoserver rpc.statd[1931]: recv_rply: can't decode RPC message!
May 28 18:40:59 faoserver vsftpd[2901]: warning: can't get client address: Connection reset by peer
May 28 18:41:44 faoserver in.tftpd[2904]: cannot bind to local socket: Permission denied
May 28 18:41:44 faoserver xinetd[2885]: START: tftp pid=2904 from=10.10.10.1
May 28 18:41:44 faoserver xinetd[2885]: EXIT: tftp status=71 pid=2904 duration=0(sec)

*************************nmap port number**************************************************************

Starting Nmap 4.62 ( http://nmap.org ) at 2008-05-28 18:42 KST
Interesting ports on faoserver (10.10.10.1):
Not shown: 1477 closed ports
PORT STATE SERVICE
67/udp open|filtered dhcps
68/udp open|filtered dhcpc
69/udp open|filtered tftp
111/udp open|filtered rpcbind
631/udp open|filtered unknown
679/udp open|filtered unknown
707/udp open|filtered unknown
835/udp open|filtered unknown
838/udp open|filtered unknown
2049/udp open|filtered nfs
32768/udp open|filtered omad


What do I need to do to in.tftpd bind to local socket?

more information***************************************************************************************

*******************************/etc/dhcpd.conf*******************************

ddns-update-style interim;
ignore client-updates;

option domain-name "localhost";
option domain-name-servers 10.10.10.1;
option routers 10.10.10.1;

default-lease-time 600;
max-lease-time 7200;

subnet 10.10.10.0 netmask 255.255.255.0 {
range 10.10.10.0 10.10.10.20;
option broadcast-address 10.10.10.255;
option subnet-mask 255.255.255.0;
}


allow booting;
allow bootp;


class "pxeclients" {
match if substring (option vendor-class-identifier, 0, 9) = "PXEClient";

filename "pxelinux.0";

next-server 10.10.10.1;
}

*******************************/etc/sysconfig/dhcpd***************************************************
# Command line options here
DHCPDARGS=eth1

*******************************/etc/sysconfig/network-scripts/ifcfg-eth1*******************************
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth1
BOOTPROTO=static
HWADDR=00:04:CA:10:38:51
IPADDR=10.10.10.1
NETWORK=10.10.10.0
NETMASK=255.255.255.0
ONBOOT=yes

*******************************/etc/xinetd.d/tftp****************************************************
# default: off

service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -l -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}

*********************************installed rpm********************************************************
dhcp-3.0.5-7.el5
dhcp-devel-3.0.5-7.el5
tftp-server-0.34-0.2.el5.rf
tftp-0.34-0.2.el5.rf
nfs-utils-1.0.9-23.el5
nfs-utils-lib-1.0.8-7.2
xinetd-2.3.14-11.i386
ftp-0.17-33.fc6
vsftpd-2.0.5-8
lftp-3.5.1-2.fc6

pxelinux.0, kernel.bzi, initrd.gz, pxelinux.cfg files in /tftpboot directory.

/tftpboot directory chmod is 777, and chown is nobody.


Any help is very much appreciated.

Thanks in advance

K.M.S

Last edited by msthing; 05-28-2008 at 10:03 PM.
 
Old 05-28-2008, 10:09 PM   #2
grizly
Member
 
Registered: Nov 2006
Location: Melbourne Australia
Distribution: Centos, RHEL, Debian, Ubuntu, Mint
Posts: 128

Rep: Reputation: 16
Is your firewall active? have you opened port 69

Are you running the tftpd service manually, and inside xinetd? Both trying to bind to the same port.. :(

Please check/post the output of:

Quote:
chkconfig --list
If you see tftpd 5:on and xinetd based services tftpd: on then your in strife, disable one!
 
Old 05-28-2008, 10:31 PM   #3
msthing
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
thank you....

My system firewall disabled. and checking "chkconfig --list"

I don't see tftpd 5.

tftp active in xinetd.

"/etc/rc.d/init.d/xinetd restart" then "tftp localhost" tested

occur a message " transfer time out "
 
Old 05-29-2008, 02:09 AM   #4
grizly
Member
 
Registered: Nov 2006
Location: Melbourne Australia
Distribution: Centos, RHEL, Debian, Ubuntu, Mint
Posts: 128

Rep: Reputation: 16
I just took your config on face value.. but it could be off a bit, try this:

Quote:
/etc/xinetd.d/tftpd

service tftp
{
protocol = udp
socket_type = dgram
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
disable = no
}
Then verify perms:
Quote:
$chmod -R 777 /tftpboot
$chown -R nobody /tftpboot
Then restart:
Quote:
service xinetd restart
Now, test that its running:
Quote:
ps -aux | grep ftp
netstat -l -u | grep ftp
Create a test-file:
Quote:
touch /tftpboot/foo
Attempt to grab it:
Quote:
tftp localhost
tftp> get foo
tftp> quit
$ls -l foo
Then try using IP:
Quote:
tftp IP.ADD.RE.SS
tftp> get foo
tftp> quit
How does that go?
 
Old 05-30-2008, 01:26 AM   #5
msthing
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you for help....!!!!!

You are very kind.....!!!!!

Connect succeed the tftp server.........

but tftpboot client doesn't download bootfiles. sorry....Could you tell me another idea...!!!

**********************/tftpboot/pxelinux.cfg/default**************************
prompt 1
default test
timeout 0

label test
kernel kernel.bzi

append initrd=initrd init=/linuxrc load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=128000 rw vga=785 splash=silent

***********************tftp Client********************************************

Managed PC Boot Agent(MBA) v4.32

pxe-boot eXecution Environment v2.43

CLIENT MAC ADDR : ** ** ** ** ** ** GUID 000000-0000-0000-0000-000000000000
CLIENT IP : 10.10.10.20 MASK : 255.255.255.0 DHCP IP : 10.10.10.1
GATEWAY : 10.10.10.1

Do not occur any message.....!!
Tftp client gets ip and than nothing....

I have a no idea.....!!!
Any help is very much appreciated.

Last edited by msthing; 05-30-2008 at 01:27 AM.
 
Old 05-30-2008, 02:54 AM   #6
grizly
Member
 
Registered: Nov 2006
Location: Melbourne Australia
Distribution: Centos, RHEL, Debian, Ubuntu, Mint
Posts: 128

Rep: Reputation: 16
http://docs.sun.com/source/817-5625-...eshooting.html
http://syslinux.zytor.com/pxe.php

I'm off for the day mate.. I'll check back later, read those see what you think.
 
Old 05-30-2008, 04:48 AM   #7
msthing
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you....mate.....

I solved problem........thank you....

God bless you...!!!
 
Old 05-30-2008, 04:52 AM   #8
grizly
Member
 
Registered: Nov 2006
Location: Melbourne Australia
Distribution: Centos, RHEL, Debian, Ubuntu, Mint
Posts: 128

Rep: Reputation: 16
Quote:
Originally Posted by msthing View Post
mate.....
Its an Australian thing, mate, we do it all the time!

So, what was the problem? More importantly, how did you fix it?
 
Old 06-01-2008, 09:21 PM   #9
msthing
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
service tftp
{
protocol = udp
socket_type = dgram
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot
disable = no
}

I use this config. I mistake pxelinux.0 file. file is not exist.

sorry...mate

God bless you...

I had done travel in West Australia 3 years ago.

I will compose nfs server.
 
  


Reply

Tags
network


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
after re-create tftp dir, tftp doesn't work anymore lastguy Linux - Networking 2 11-16-2007 04:33 PM
tftp issue, unable to transfer kernel image using tftp to boot ltsp-client noobs4linux Linux - Networking 1 02-07-2007 02:53 AM
TFTP server yhus Linux - Networking 5 06-18-2006 02:44 PM
How do I configure tftp to work with firewall on fedora core 4 rtjazz Linux - Security 1 01-23-2006 05:16 PM
TFTP Problem? it will not work! m1anh Linux - General 1 02-02-2003 05:24 AM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration