LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 12-15-2016, 11:10 AM   #1
rmin75
LQ Newbie
 
Registered: Dec 2016
Posts: 4

Rep: Reputation: Disabled
configure: error: Unable to detect ICU prefix or no failed.


Hi,

I'm hoping someone can assist me. I'm trying to compile and install php-5.6.28 on a RHEL 6.7 but I'm getting this at the end:

"checking for location of ICU headers and libraries... not found
configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works."


I've tried adding the EPEL repo and even tried manually downloding the "libicu-devel-4.2.1-9.5.x86_64.rpm" but I'm getting

"warning: libicu-devel-4.2.1-9.5.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 0b8f71fe: NOKEY
error: Failed dependencies:
libicu = 4.2.1-9.5 is needed by libicu-devel-4.2.1-9.5.x86_64"




Thank you in advance!
 
Old 12-15-2016, 02:15 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
> libicu = 4.2.1-9.5 is needed by libicu-devel-4.2.1-9.5.x86_64
Install libicu at the same time as libicu-devel.
 
Old 12-15-2016, 02:38 PM   #3
rmin75
LQ Newbie
 
Registered: Dec 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you AlucardZero. I did try that. However, I'm getting the following

#yum install libicu
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Package libicu-4.2.1-14.el6.x86_64 already installed and latest version
 
Old 12-15-2016, 02:40 PM   #4
rmin75
LQ Newbie
 
Registered: Dec 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
I saw this post from roundcube.

Recompiling php and adding local here: --with-icu-dir=/usr/local

Do you think this will work?
 
Old 12-15-2016, 03:02 PM   #5
rmin75
LQ Newbie
 
Registered: Dec 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Nope. Tried it and it didn't work.
 
Old 12-17-2016, 03:42 PM   #6
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
This is what I mean by at the same time:
yum install libicu libicu-devel
 
Old 02-08-2017, 07:10 AM   #7
Andrew Burton
LQ Newbie
 
Registered: Feb 2017
Posts: 1

Rep: Reputation: 0
error

Thanks for the to find the error in it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: expected an absolute directory name for --prefix: -prefix=/home/jeo Nownuri Linux - Newbie 2 03-28-2015 07:40 AM
./configure --prefix= plan9 Slackware 5 01-03-2013 04:44 AM
./configure --prefix ?? itzig Linux - Software 10 02-03-2006 07:30 PM
kde prefix error when running ./configure hoopyfrood Linux - Software 1 04-25-2004 05:40 PM
xemacs configure unable to detect x11 window system macshark Linux - Software 0 11-22-2003 02:03 AM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 06:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration