-   Linux - Enterprise (
-   -   Centos Kernel Upgrade Issue (

brentd 02-13-2009 11:53 AM

Centos Kernel Upgrade Issue
I've got a machine running Centos 5.2 I had had previously compiled kernel version and it's been running fine. I now want to upgrade to but can't seem to get the new kernel to boot. Everything goes fine right up to the point where it tries to find the root filesystem then I get a kernel panic. My root partition is on an Areca SATA raid controller that uses the arcmsr driver module, but is also contained inside an LVM group.

The error message that I get before the panic is that VolGroup00 can't be found. I can't tell if it's because the arcmsr module is not being loaded or if it has something to do with the LVM support. I can't find any options in menuconfig to turn LVM support on or off.

I've tried compiling the arcmsr support both as a module and directly into the kernel, and I get the same message either way. Even tried running mkinitrd was --preload=arcmsr to no avail.

Did something change between and that would affect the LVM system?

kyle_p 03-06-2009 05:54 PM

I don't believe so. Did you use an identical config? Did you make an initrd image?

alex1983-0112 03-07-2009 02:42 AM

Did you check that SATA was included in the new kernel config?

brentd 03-09-2009 09:47 AM

The config for the new kernel was mostly identical. I added the options for tickless system and increased the timer rate to 1000hz, but beyond that nothing much changed. I made sure that I compiled the appropriate sata modules and drivers for my raid card and then made sure I built an initrd with those modules included. Still get the same result.

kyle_p 03-09-2009 04:27 PM

So did you make dep and make rpm after menuconfig?


make clean && make mrproper  && cp /boot/config-`uname -r` ./.config && make menuconfig

make dep

make rpm

rpm -ihv <new-kernel-build>.rpm

vi /boot/grub/menu.lst

/sbin/init 6

All times are GMT -5. The time now is 01:02 PM.