LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 05-24-2014, 12:45 PM   #1
RandyTech
Member
 
Registered: Oct 2010
Posts: 62

Rep: Reputation: 3
Centos 6 Display -- Run Level 3 Screen Resolution


Run level 3 boot (no GUI) in the good old ancient RedHat all the way up through CentOS 5 always gave me the 80x25 character display (640x400 resolution). I need to get back to that 80x25 character display on the CentOS 6 main console.

To be clear, I do not use nor want GUI. I am talking straight run level 3 mode. Tried all the suggestions I could find referring to edit of the /etc/grub.conf file. Other than forcing the "Unidentified video mode number" prompt during the boot if I had a bad "vga=<value>", changes to grub.conf had no affect. Final results when I arrive at the console login prompt is always 100x37 character display (800x600).

Thanks in advance if you can help
 
Old 05-25-2014, 07:33 PM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Manjaro
Posts: 1,775

Rep: Reputation: 423Reputation: 423Reputation: 423Reputation: 423Reputation: 423
What happens if you add nomodeset to the kernel line in grub.cfg (and reboot, of course)? On my Fedora 21 system (Nvidia C78 onboard graphics), that keeps me in 80x25 mode throughout a runlevel 3 boot. If that works for you, add nomodeset to the GRUB_CMDLINE_LINUX line in /etc/default/grub so that installing a new kernel will incorporate nomodeset into yur newly-generated grub.cfg file.
 
Old 05-25-2014, 09:47 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870
The vga= option was deprecated when video drivers that support KMS (kernel mode setting) were introduced. If you want to run a resolution of 640x400 try the video= option instead, like
Code:
video=640x400@60
for that resolution at 64Hz refresh rate.
I would not recommend the nomodeset option for more than testing, it usually effectively disables the video driver, which can also have an effect on power saving modes.

Last edited by TobiSGD; 05-25-2014 at 09:48 PM.
 
Old 05-26-2014, 08:50 AM   #4
RandyTech
Member
 
Registered: Oct 2010
Posts: 62

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by RockDoctor View Post
What happens if you add nomodeset to the kernel line in grub.cfg (and reboot, of course)?
Hi RockDoctor ... Works perfectly as far as I have seen ... so far

Your post came in just after I stumbled into the 'nonodeset' term at another forum and finished testing it. Not posted there as a remedy to this problem per say, but figured I'd try it anyway. Nonetheless, it works so *many* thanks for sharing. Now there is at least one forum that does post 'nomodeset' as a remedy!!

Noticing too, our next poster (TobiSGD) recommends *not* using this as a solution. I may end up having to test his warning because his proposed solution has some issues.
 
Old 05-26-2014, 09:28 AM   #5
RandyTech
Member
 
Registered: Oct 2010
Posts: 62

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by TobiSGD View Post
The vga= option was deprecated when video drivers that support KMS (kernel mode setting) were introduced. If you want to run a resolution of 640x400 try the video= option instead,...
Hi TobuSGD ... "Depreciated" ... so I guess that would explain the inferior performance of the new alternative. Seems to be trend in each new *enhanced* release of Centos.

Don't mean to sound like a jerk. Very much *do* appreciate your contribution! This "vga= depreciated" comment you made is first I encountered anywhere. In fact, only references I found leading to grub.conf remedies suggested the "vga=value" method. Did not encounter a single post with any mention of the newer "video=" alternative. Knowing that option now and searching for that specifically , I do get many hits so I guess I just wasn't using the right search terms.

Getting back to your proposed "video=640x400" edit. Tried that and unlike the "vga=0x300" which also failed, I got *no video at all*!! Hence the comment above about inferior performance on the new alternative. At least the old way it gives a picklist and gives me a display no matter what I do, opposed to "video=640x400" going straight into a blank unresponsive screen.

So, this 640x400 turns out is "not an available mode" according to every Centos resource I encountered *on this machine*. Which seems really stupid since all previous RH and Centos releases worked fine with 640x400 on this box. Even the BIOS post comes up 640x400 so I don't understand the big emphasis with Centos (or RH if you prefer) trying to block it.

I did try your method using the lowest "available mode" on my machine so "video=640x480" did boot fine, lit up all VT screens at 640x480 and seem to stay locked in at that resolution as one might hope. Still, not what I was looking for. I wanted 640x400 and your method at that resolution only gives a blank screen, so it looks like 'nomodeset' is the only functional option for us.

Have not encountered any 'nomodeset' repercussions in our software yet. These installations never see a GUI environment so I can only hope at this point that your warning will not come back to bite us with a big "told you so!!! LOL"

Thanks again for sharing!!
 
Old 05-26-2014, 09:34 AM   #6
RandyTech
Member
 
Registered: Oct 2010
Posts: 62

Original Poster
Rep: Reputation: 3
Oh, BTW ... we also require a home brew custom kernel for legacy PTY support, so we block auto-updates on the kernel and our grub.conf only changes when we say so, and how we say so.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Locale or run level - cannot open display message konzo Linux - Newbie 5 01-14-2010 04:32 PM
Centos 5.3 display resolution issue Net_Spy Linux - Hardware 1 08-02-2009 10:26 PM
SUSE unable show graphics mode run level and screen resolution is not supporting vineethshyam SUSE / openSUSE 2 09-24-2006 10:04 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 12:50 PM
Resolution in run level 3 strimp099 Linux - General 1 10-26-2004 12:22 PM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration