-   Linux - Enterprise (
-   -   Cannot configure Linux to authenticate against Active Directory (

Cyberitas 10-29-2007 07:09 PM

Cannot configure Linux to authenticate against Active Directory
My company recently decided to use Microsoft Active Directory to streamline our authentication and computer management tasks. Of course, the Windows boxes all join the domain and are fine. The Mac boxes do as well. The only system that I am having issues with are the Linux servers. I have research AD authentication and domain memebership for linux systems for about two weeks now with no favorable results. I have read all about Windows SFU, NIS, Kerberos, LDAP, Samba, PAM, and more but the only thing I have accomplished is joining the machine to the domain.

I come from a strong Windows Desktop and Server background and am proficient in Linux enough to be dangerous. I am very proficient in Active Directory, but only as it relates to Windows. I have never tried joining other machines before.

Can someone give me, or point me in the right direction of, a guide that goes, step by step, how to configure Linux to authenticate the users through both console and SSH? I have tried everything I can think, and gone through so many vague "how-to's" that I believe I could write my own vague "how-to." I have tried through GNOME, KDE, and CLI on CentOS, RHEL4 & 5, and openSUSE.

From what I feel, I am following the directions correctly, but for the life of me cannot get this to work. I have read threads from this website, as well as plenty of others with no luck.

Can someone help me out?

linux_dude_77 10-31-2007 10:00 AM

What kind of Linux distro are you working with?

farslayer 10-31-2007 10:12 AM

Something like this ?

Single-Sign-On on Linux using LDAP with Active Directory

This article discusses how you can integrate Linux into a Windows-based network by making it authenticate against an Active Directory server and having it get passwd and group information from Active Directory as well.

It starts by giving a quick rundown on traditional authentication mechanisms in UNIX, then delves into the details of setting up NSS and PAM with Active Directory.

here is another article..

Cyberitas 10-31-2007 10:40 AM

linux_dude, I am working with RHEL4 & 5, CentOS 4.5 and the latest build of openSUSE.

farslayer, I will try that out. Thanks!

Cyberitas 11-01-2007 11:56 AM

OK, I got it working with winbind finally. Not sure what the problems were before. I just ran authconfig and select winbind for my user and auth info and it is working great.

All times are GMT -5. The time now is 07:18 AM.