-   Linux - Embedded & Single-board computer (
-   -   USB peripheral device not found on USB OTG port with Linux 3.0.0 kernel (

lmorda 04-17-2012 08:43 PM

USB peripheral device not found on USB OTG port with Linux 3.0.0 kernel
I am having problems with a USB OTG port on my embedded system. I have a Gumstix Overo Air embedded computer running on a Stagecoach expansion board. The Overo runs an embedded distribution called Angstrom which uses Linux kernel 3.0.0. I am trying to connect a USB peripheral device. This device is a General Dynamics radio. The radio is usually connected to a Windows or Linux desktop with a USB standard A 2.0 cable. A Belcarra CDC ethernet driver is used to connect to the radio over tcp/ip.

The connection to the Overo computer USB OTG port is unreliable. Sometimes the connection is found, and sometimes it is not. I cannot seem to repeat the issue. It's very important for my system to always find the radio when it is plugged into the USB OTG port. I looked at '/var/log/messages' and also the output from 'lsusb -v' Basically, both just output information about the radio when it is found, and don't output anything about the radio or that USB port when the radio is not found.

How can I debug this problem? I've tried the Gumstix mailing list but have not gotten any help. I'm hoping this is a Linux issue and I can get some help on here!! :-/ I'm sorry in advance if this forum does not cover embedded questions.

Any help is very very much appreciated. Thanks.

will.larson 04-28-2012 12:56 PM

Have you tried earlier or later kernel releases? Are you compiling your own kernel?

Are you using a board config files. How is the radio device being powered.

All times are GMT -5. The time now is 10:05 AM.