LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices


Reply
  Search this Thread
Old 09-08-2013, 04:53 AM   #1
golden_boy615
Member
 
Registered: Dec 2008
Distribution: Ubuntu Fedora
Posts: 445

Rep: Reputation: 17
ssh and mysql does not start after bootup on cubieboard


Hi
I have A10 cubieborad with ubnutu inside it was working fine but after rebooting it its mysql and ssh dooes not start these are my information:

part of boot process which shows error
Quote:
<6>hub 5-0:1.0: USB hub found
<6>hub 5-0:1.0: 1 port detected
<6>Initializing USB Mass Storage driver...
<6>usbcore: registered new interface driver usb-storage
<6>USB Mass Storage support registered.
<6>usbcore: registered new interface driver ums-alauda
<6>usbcore: registered new interface driver ums-cypress
<6>usbcore: registered new interface driver ums-datafab
<6>usbcore: registered new interface driver ums_eneub6250
<6>usbcore: registered new interface driver ums-freecom
<6>usbcore: registered new interface driver ums-isd200
<6>usbcore: registered new interface driver ums-jumpshot
<6>usbcore: registered new interface driver ums-karma
<6>usbcore: registered new interface driver ums-onetouch
<6>usbcore: registered new interface driver ums-realtek
<6>usbcore: registered new interface driver ums-sddr09
<6>usbcore: registered new interface driver ums-sddr55
<6>usbcore: registered new interface driver ums-usbat
<6>mousedev: PS/2 mouse device common for all mice
<6>input: sun4i-ir as /devices/virtual/input/input0
IR Initial OK
sunxi RTC version 0.1
<6>sunxi-rtc sunxi-rtc: sunxi_rtc_probe tmp_data = 380248073
<6>sunxi-rtc sunxi-rtc: sunxi_rtc_gettime
<6>sunxi-rtc sunxi-rtc: read time 2013-9-8 9:34:3
<6>sunxi-rtc sunxi-rtc: sunxi_rtc_gettime
<6>sunxi-rtc sunxi-rtc: read time 2013-9-8 9:34:3
<6>sunxi-rtc sunxi-rtc: rtc core: registered rtc as rtc0
<6>i2c /dev entries driver
!!! base_Addr = 0xf1c2ac00
config i2c gpio with gpio_config api
twi0, apb clock = 24000000
<6>axp_mfd 0-0034: AXP (CHIP ID: 0x41) detected
<6>I2C: i2c-0: AW16XX I2C adapter
!!! base_Addr = 0xf1c2b000
twi1, apb clock = 24000000
<6>I2C: i2c-1: AW16XX I2C adapter
!!! base_Addr = 0xf1c2b400
twi2, apb clock = 24000000
<6>I2C: i2c-2: AW16XX I2C adapter
<6>lirc_dev: IR Remote Control driver registered, major 250
<6>IR NEC protocol handler initialized
<6>IR RC5(x) protocol handler initialized
<6>IR RC6 protocol handler initialized
<6>IR JVC protocol handler initialized
<6>IR Sony protocol handler initialized
<6>IR RC5 (streamzap) protocol handler initialized
<6>IR SANYO protocol handler initialized
<6>IR MCE Keyboard/mouse protocol handler initialized
<6>IR LIRC bridge handler initialized
[cedar dev]: install start!!!
[cedar dev]: install end!!!
[ace_drv] start!!!
[ace_drv] init end!!!
[pa_drv] start!!!
[pa_drv] init end!!!
<6>axp20_ldo1: 1300 mV
<6>axp20_ldo2: 1800 <--> 3300 mV at 3000 mV
<6>axp20_ldo3: 700 <--> 3500 mV at 2800 mV
<6>axp20_ldo4: 1250 <--> 3300 mV at 2800 mV
<6>axp20_buck2: 700 <--> 2275 mV at 1400 mV
<6>axp20_buck3: 700 <--> 3500 mV at 1250 mV
<6>axp20_ldoio0: 1800 <--> 3300 mV at 2800 mV
<6>input: axp20-supplyer as /devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.41/input/input1
<4>axp20_ldo2: Failed to create debugfs directory
[ 1.430000] axp20_ldo2: Failed to create debugfs directory
<6>sunxi_wdt: sunxi WatchDog Timer Driver v1.0
<6>sunxi_wdt: initialized (timeout=23s, nowayout=0)
<6>Bluetooth: HCI UART driver ver 2.2
<6>Bluetooth: HCI H4 protocol initialized
<6>Bluetooth: HCI BCSP protocol initialized
<6>Bluetooth: HCILL protocol initialized
<6>cpuidle: using governor ladder
<6>cpuidle: using governor menu
[mmc_pm]: no sdio card used in configuration
[mmc]: sunximmc_init
[mmc]: sunxi mmc controller using config : 0xb
[mmc]: sunxi-mmc.0: pdev->name: sunxi-mmc, pdev->id: 0
[mmc]: mmc 0 power off !!
[mmc]: mmc0 Probe: base:0xf1c0f000 irq:32 dma:0 pdes:0xee80c000, ret 0.
[mmc]: sunxi-mmc.1: pdev->name: sunxi-mmc, pdev->id: 1
[mmc]: mmc 1 power off !!
[mmc]: mmc1 Probe: base:0xf1c10000 irq:33 dma:0 pdes:0xee814000, ret 0.
[mmc]: sunxi-mmc.3: pdev->name: sunxi-mmc, pdev->id: 3
[mmc]: mmc 3 power off !!
[mmc]: mmc3 Probe: base:0xf1c12000 irq:35 dma:0 pdes:0xee818000, ret 0.
<6>sunxi_leds driver init
<7>Registered led device: greenh20:led1
<7>Registered led device: blueh21:led2
<6>ledtrig-cpu: registered to indicate activity on CPUs
<6>usbcore: registered new interface driver usbhid
<6>usbhid: USB HID core driver
<6>logger: created 256K log 'log_main'
<6>logger: created 256K log 'log_events'
<6>logger: created 256K log 'log_radio'
<6>logger: created 256K log 'log_system'
enter sun4i Audio codec!!!
<6>sun4i audio support initialized
sun4i Audio codec successfully loaded..
<6>IPv4 over IPv4 tunneling driver
<6>TCP: cubic registered
<6>Initializing XFRM netlink socket
<6>NET: Registered protocol family 17
<6>NET: Registered protocol family 15
<6>Bluetooth: RFCOMM TTY layer initialized
<6>Bluetooth: RFCOMM socket layer initialized
<6>Bluetooth: RFCOMM ver 1.11
<6>Bluetooth: BNEP (Ethernet Emulation) ver 1.3
<6>Bluetooth: BNEP filters: protocol multicast
<6>8021q: 802.1Q VLAN Support v1.8
[mmc_pm]: No sdio card, please check your config !!
<5>Registering the dns_resolver key type
<6>VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
<5>Registering SWP/SWPB emulation handler
<4>axp20_buck2: Failed to create debugfs directory
[ 1.630000] axp20_buck2: Failed to create debugfs directory
<6>registered taskstats version 1
<6>I2C: i2c-3: HDMI I2C adapter
<6>disp clks: lcd 74250000 pre_scale 1 hdmi 74250000 pll 297000000 2x 0
<6>Console: switching to colour frame buffer device 160x45
<4>axp20_buck3: incomplete constraints, leaving on
[ 2.320000] axp20_buck3: incomplete constraints, leaving on
<4>axp20_buck2: incomplete constraints, leaving on
[ 2.340000] axp20_buck2: incomplete constraints, leaving on
<4>axp20_ldo4: incomplete constraints, leaving on
[ 2.350000] axp20_ldo4: incomplete constraints, leaving on
<4>axp20_ldo3: incomplete constraints, leaving on
[ 2.360000] axp20_ldo3: incomplete constraints, leaving on
<4>axp20_ldo2: incomplete constraints, leaving on
[ 2.370000] axp20_ldo2: incomplete constraints, leaving on
<4>axp20_ldo1: incomplete constraints, leaving on
[ 2.380000] axp20_ldo1: incomplete constraints, leaving on
<6>sunxi-rtc sunxi-rtc: sunxi_rtc_gettime
<6>sunxi-rtc sunxi-rtc: read time 2013-9-8 9:34:4
<6>sunxi-rtc sunxi-rtc: setting system clock to 2013-09-08 09:34:04 UTC (1378632844)
<6>ALSA device list:
<6> #0: sun4i-CODEC Audio Codec
<6>Freeing init memory: 2352K
<6>EXT4-fs (nandc): mounted filesystem with writeback data mode. Opts: data=writeback
<6>EXT4-fs (nandd): mounted filesystem with writeback data mode. Opts: data=writeback
<6>EXT4-fs (nande): mounted filesystem with writeback data mode. Opts: data=writeback
<6>EXT4-fs (nandf): mounted filesystem with writeback data mode. Opts: data=writeback
<4>init: ureadahead main process (70) terminated with status 5
[ 3.040000] init: ureadahead main process (70) terminated with status 5
<4>init: ssh main process (172) killed by SEGV signal
<4>init: ssh main process ended, respawning
<30>udevd[176]: starting version 175
<4>init: ssh main process (184) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (187) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (190) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (194) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (198) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (201) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (204) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (207) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (210) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (213) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (216) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (219) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (222) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (227) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (230) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (233) killed by SEGV signal
<4>init: ssh respawning too fast, stopped
<6>usbcore: registered new interface driver rtl8192cu
<4>init: plymouth main process (71) killed by ABRT signal
<4>init: plymouth-splash main process (331) terminated with status 2
<4>wemac wemac.0: WARNING: no IRQ resource flags set.
<6>wemac wemac.0: eth0: link down
<4>init: failsafe main process (353) killed by TERM signal

<4>init: ssh main process (469) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (483) killed by SEGV signal
<4>init: ssh main process ended, respawning
<6>wemac wemac.0: eth0: link up, 100Mbps, full-duplex, lpa 0x4DE1
<4>init: ssh main process (507) killed by SEGV signal
<4>init: ssh main process ended, respawning
Last login: Sun Sep 8 13:56:07 IRDT 2013 on tty1
<4>init: ssh main process (522) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (526) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (538) killed by SEGV signal
<4>init: ssh main process ended, respawning
Welcome to Linaro 13.04 (GNU/Linux 3.4.43 armv7l)

* Documentation: https://wiki.linaro.org/
New release '13.04' available.
Run 'do-release-upgrade' to upgrade to it.

<4>init: ssh main process (553) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (556) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (560) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (563) killed by SEGV signal
<4>init: ssh main process ended, respawning
<4>init: ssh main process (568) killed by SEGV signal
<4>init: ssh respawning too fast, stopped
root@cubieboard-server:~# <4>init: mysql main process (502) terminated with status 1
<4>init: mysql main process ended, respawning
<4>usbserial: module_layout: kernel tainted.
<4>Disabling lock debugging due to kernel taint
<6>usbcore: registered new interface driver usbserial
<6>usbserial: USB Serial Driver core
<6>usbcore: registered new interface driver pl2303
<6>USB Serial support registered for pl2303
<4>init: plymouth-stop pre-start process (624) terminated with status 1
<4>init: tty1 main process (625) killed by TERM signal
<4>init: mysql post-start process (506) terminated with status 1
<4>init: mysql main process (678) terminated with status 1
<4>init: mysql main process ended, respawning
<4>init: mysql post-start process (679) terminated with status 1
<4>init: mysql main process (833) terminated with status 1
<4>init: mysql main process ended, respawning
<4>init: mysql post-start process (834) terminated with status 1
<4>init: mysql main process (880) terminated with status 1
<4>init: mysql main process ended, respawning
<4>init: mysql post-start process (881) terminated with status 1
<4>init: mysql main process (917) terminated with status 1
<4>init: mysql respawning too fast, stopped
ssh and mysql startation:
Quote:
root@cubieboard-server:~# sshd
Segmentation fault
root@cubieboard-server:~# /etc/init.d/mysql restart
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service mysql restart

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) and then start(8) utilities,
e.g. stop mysql ; start mysql. The restart(8) utility is also available.
<4>init: mysql main process (5390) terminated with status 1
<4>init: mysql main process ended, respawning
<4>init: mysql post-start process (5391) terminated with status 1
<4>init: mysql main process (5427) terminated with status 1
<4>init: mysql main process ended, respawning
<4>init: mysql post-start process (5428) terminated with status 1
<4>init: mysql main process (5464) terminated with status 1
<4>init: mysql respawning too fast, stopped
start: Job failed to start
root@cubieboard-server:~#
my ubuntu version on cubie:
Quote:
root@cubieboard-server:~# cat /etc/*release
DISTRIB_ID=Linaro
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Linaro 13.04"
NAME="Linaro"
VERSION="13.04"
ID=linaro
ID_LIKE=ubuntu
PRETTY_NAME="Linaro 13.04"
VERSION_ID="13.04"
part of mysql error log:
Quote:
130908 14:08:48 [Note] /usr/sbin/mysqld: Shutdown complete

130908 14:08:49 [Note] Plugin 'FEDERATED' is disabled.
130908 14:08:49 InnoDB: The InnoDB memory heap is disabled
130908 14:08:49 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130908 14:08:49 InnoDB: Compressed tables use zlib 1.2.7
130908 14:08:49 InnoDB: Using Linux native AIO
130908 14:08:49 InnoDB: Initializing buffer pool, size = 128.0M
130908 14:08:49 InnoDB: Completed initialization of buffer pool
130908 14:08:49 InnoDB: highest supported file format is Barracuda.
InnoDB: No valid checkpoint found.
InnoDB: If this error appears when you are creating an InnoDB database,
InnoDB: the problem may be that during an earlier attempt you managed
InnoDB: to create the InnoDB data files, but log file creation failed.
InnoDB: If that is the case, please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/...ng-innodb.html
130908 14:08:49 [ERROR] Plugin 'InnoDB' init function returned error.
130908 14:08:49 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
130908 14:08:49 [ERROR] Unknown/unsupported storage engine: InnoDB
130908 14:08:49 [ERROR] Aborting

130908 14:08:49 [Note] /usr/sbin/mysqld: Shutdown complete

130908 14:08:50 [Note] Plugin 'FEDERATED' is disabled.
130908 14:08:50 InnoDB: The InnoDB memory heap is disabled
130908 14:08:50 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130908 14:08:50 InnoDB: Compressed tables use zlib 1.2.7
130908 14:08:50 InnoDB: Using Linux native AIO
130908 14:08:50 InnoDB: Initializing buffer pool, size = 128.0M
130908 14:08:50 InnoDB: Completed initialization of buffer pool
130908 14:08:50 InnoDB: highest supported file format is Barracuda.
InnoDB: No valid checkpoint found.
InnoDB: If this error appears when you are creating an InnoDB database,
InnoDB: the problem may be that during an earlier attempt you managed
InnoDB: to create the InnoDB data files, but log file creation failed.
InnoDB: If that is the case, please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/...ng-innodb.html
130908 14:08:50 [ERROR] Plugin 'InnoDB' init function returned error.
130908 14:08:50 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
130908 14:08:50 [ERROR] Unknown/unsupported storage engine: InnoDB
130908 14:08:50 [ERROR] Aborting

130908 14:08:50 [Note] /usr/sbin/mysqld: Shutdown complete
I did nothing to it I just restarted it what is wrong what should I do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL Cannot start SSH tunnel manager?? michaelinux Linux - Software 4 09-20-2012 07:47 AM
LXer: Cubieboard: Raspberry Pi competitor with SATA port LXer Syndicated Linux News 0 09-12-2012 01:11 AM
Can MySQL log on via SSH/bash? mysql:x:27:101:MySQL Server:/var/lib/mysql:/bin/bash Ujjain Linux - Newbie 2 04-24-2009 02:21 PM
I have RHEL 5.0 and MySQL start problem, my MySQL server doesn't start rsatya Linux - Enterprise 4 02-03-2009 12:04 PM
Auto start Apach and MYSQL on bootup tekmann33 Linux - Newbie 4 06-02-2008 01:18 AM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration