LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
LinkBack Search this Thread
Old 12-23-2008, 07:10 AM   #1
yagabey
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Rep: Reputation: 0
"Protocol not supported error" after mount


Hello friends,
I have an ads5121rev4 board. I couldn't manage to start linux over nfs. It gets stuck after "freeing init memory" part.
So i decided to start linux from jffs2 image in the flash. It starts without any problems. Next i tried to mount an nfs folder.
Code:
mount -o nolock 10.18.6.233:/home/yg/mpc5121/nfs yigit
this time it gives an error:

Code:
mount: Mounting 10.18.6.233:/home/yg/mpc5121/nfs on yigit failed: Protocol not supported
I can ping to/from the board, no problem with network..What may be the problem with mounting? Do you think both problems are nfs configuration related? What can i do to solve?

Linux kernel version :Linux freescale 2.6.24.6

Thanks in advance...

 
Old 12-24-2008, 01:38 AM   #2
eco
Member
 
Registered: May 2006
Location: BE
Distribution: Debian/Gentoo
Posts: 412

Rep: Reputation: 48
Hi,

I suspect all you need is to load the NFS module into the kernel.

# modprobe <nfs_module>


Look it /lib/modules for the name of the nfs module.
 
Old 04-02-2009, 04:45 AM   #3
_raziel_
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
Hi I have the same problem, did you solve it? If so, please tell me how you did. Thanks.

Quote:
Originally Posted by yagabey View Post
Hello friends,
I have an ads5121rev4 board. I couldn't manage to start linux over nfs. It gets stuck after "freeing init memory" part.
So i decided to start linux from jffs2 image in the flash. It starts without any problems. Next i tried to mount an nfs folder.
Code:
mount -o nolock 10.18.6.233:/home/yg/mpc5121/nfs yigit
this time it gives an error:

Code:
mount: Mounting 10.18.6.233:/home/yg/mpc5121/nfs on yigit failed: Protocol not supported
I can ping to/from the board, no problem with network..What may be the problem with mounting? Do you think both problems are nfs configuration related? What can i do to solve?

Linux kernel version :Linux freescale 2.6.24.6

Thanks in advance...

 
Old 04-03-2009, 12:39 AM   #4
yagabey
LQ Newbie
 
Registered: Dec 2008
Posts: 5

Original Poster
Rep: Reputation: 0
As i remember, the problem was with kernel configuration. You should select "nfs support" and a few other things...
 
Old 02-02-2011, 03:10 AM   #5
flipflap
LQ Newbie
 
Registered: Feb 2011
Posts: 4

Rep: Reputation: 0
Red face

Quote:
Originally Posted by yagabey View Post
As i remember, the problem was with kernel configuration. You should select "nfs support" and a few other things...
I have the same problem. Can someone explain in details how to fix it ? What I have to change in terms of nfs configuration ?
 
Old 02-02-2011, 05:46 AM   #6
flipflap
LQ Newbie
 
Registered: Feb 2011
Posts: 4

Rep: Reputation: 0
Just to be more detailed I have a board Spear300 from where I'm trying to mount an nfs folder from a linux fedora 13 server and the error is:

# mount 192.168.4.105:/share /mnt/home
mount: mounting 192.168.4.105:/share on /mnt/home failed: Protocol not supported

Last edited by flipflap; 02-02-2011 at 08:03 AM.
 
Old 02-03-2011, 09:12 AM   #7
cnxsoft
Member
 
Registered: Nov 2010
Location: Thailand
Distribution: Fedora 12, Ubuntu 10.10
Posts: 166

Rep: Reputation: 29
You just need to do make menuconfig and enable NFS:

Quote:
NFS file system support (CONFIG_NFS_FS) [y]
It can be compiled part of the kernel or as a module.

If it is a module, you may need to load the driver something like

Quote:
modprobe nfs
 
Old 02-03-2011, 10:19 AM   #8
flipflap
LQ Newbie
 
Registered: Feb 2011
Posts: 4

Rep: Reputation: 0
I run menuconfig but the answer is:

[root@fedora13 Python-2.6]# make menuconfig
make: *** No rule to make target `menuconfig'. Stop.

What should I do ?

Thx
 
Old 02-03-2011, 04:42 PM   #9
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,390
Blog Entries: 2

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Quote:
Originally Posted by cnxsoft View Post
You just need to do make menuconfig and enable NFS:
A slight oversimplification. You need to re-build and install the kernel. You would do so by using the menuconfig to set the appropriate variables for building the NFS client code as either a built-in or loadable module.
It may already exist as a loadable module. Have you tried loading that?

--- rod.

Last edited by theNbomr; 02-04-2011 at 11:14 AM. Reason: typo fix
 
Old 02-04-2011, 01:52 AM   #10
flipflap
LQ Newbie
 
Registered: Feb 2011
Posts: 4

Rep: Reputation: 0
do you mean on the client side so on the board side ?

a-

Last edited by flipflap; 02-04-2011 at 09:24 AM.
 
Old 02-04-2011, 11:13 AM   #11
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,390
Blog Entries: 2

Rep: Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900Reputation: 900
Whatever side is reporting the 'Protocol not supported' error. I think that is what I meant when I said 'set the appropriate variables for building the NFS client code'.

On the server side, there is no kernel component.

--- rod.

Last edited by theNbomr; 02-04-2011 at 11:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
in Konqueror: "Protocol not supported VNC" lumix Linux - Networking 1 06-24-2008 09:32 AM
konqueror - "devices:" ? protocol not supported divukman Debian 4 12-24-2005 08:54 AM
connecting openbsd to linux nfs mount - "unsupported protocol" error animehair *BSD 4 03-28-2005 01:21 AM
gaim not connecting to msn "protocol not supported" drussi Linux - Newbie 2 02-21-2004 06:22 PM
NTFS Mount Error - "Cluster Size Not Supported" dougweiser Linux - Software 2 01-22-2002 08:57 AM


All times are GMT -5. The time now is 01:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration