-   Linux - Embedded & Single-board computer (
-   -   Mounting jffs2 header gives superblock error (

mbee 12-05-2012 04:43 PM

Mounting jffs2 header gives superblock error
Hi, I have used firmware mod kit to unpack an img file which splits the file up. I end up with a header file which gives the following:

# binwalk rootfs.jffs2

12464 0x30B0 gzip compressed data, from Unix, last modified: Wed Nov 9 04:24:07 2011, max compression
497472 0x79740 JFFS2 filesystem data little endian, JFFS node length: 50794
I used dd to split out the jffs2 section:


# binwalk header.jffs2

485007 0x7668F JFFS2 filesystem data little endian, JFFS node length: 50794
I have tried mounting both files following as many instructions as I can find on google but always get the same error. This is what I get when using a script:

./ header.jffs2
mount: /tmp/mtdblock0: can't read superblock
This has been a learning curve for me, I have no idea what a superblock is so would really appreciate help or ideas.
Thanks in advance

theNbomr 12-17-2012 09:15 AM

I don't know what is supposed to do or how it works. If it tries to mount the filesystem image on a loop device, then I can only suggest that the image is either corrupted or is not really what it is alleged to be. The jffs2 filesystem type is not always fully supported in many Linux distributions and may require an add-on package. To mount a jffs2 filesystem, your kernel will need to have built-in support, or (I think) can use a loadable module to support the jffs2 filesystem type. Not sure if the error message you cited implies anything about that; it might indicate that the kernel knows jffs2.

--- rod.

mbee 12-19-2012 06:21 PM

Many thanks for your thoughts. The script uses a loop device. I have tried several methods now and get the same error so you must be right that it is not jffs2 or corrupted.
It is from Teac who supply a linux source and build script so I am now trying that but get linux-gcc not found even after installing it.

All times are GMT -5. The time now is 05:48 AM.