-   Linux - Embedded & Single-board computer (
-   -   kernel boot process hangs after : Now booting the kernel (

mangeshwanjari 05-21-2009 03:32 AM

kernel boot process hangs after : Now booting the kernel
Respected sir,

I have solved almost every problem but the one with booting kernel is still there.

Actually I'm using EDK 8.2i to built the montavista kernel on the xilinx xup virtex II pro FPGA board as per the tutorial by J. W. Donaldson.
I'm using UARTLite and no ethernet configuration. I have created the system.ace file and put it on the CF card.

Now when I boot the kernel, I get:

loaded at: 00400000 004611E0
board data at: 0045E138 0045E150
relocated to: 00405318 00405330
zimage at: 0040581D 0045D524
avail ram: 00462000 10000000

Linux/PPC load: console=ttyS0,9600
Uncompressing Linux...done.
Now booting the kernel

and then system hangs in windows and reboots in Linux on minicom.
I'm not very sure whether it is crashed or hangs or in infinite loop.

I'm using only 256 MB RAM so that is also not a problem which have been stated for this bug in the tutorial.
I'm stuck up at the point.

Please, please help me.

Best regards
Mangesh Wanjari

greplinux 05-22-2009 12:10 AM

Try stopping firewall services.

mangeshwanjari 05-22-2009 11:09 PM

Thank you Mr GrepLinux for quick reply.

But it does not work. Already no firewall service is on.
Still I have tried to do that.

I will appreciate if somebody can help me.

Best Regards
Mangesh Wanjari

greplinux 05-25-2009 02:35 AM

Which boot loader are you using?
Can you please post the boot time commands you are using?

mangeshwanjari 05-25-2009 02:49 AM

Here I'm not having any stadard bootloader like grub or lilo.
I'm using SystemACE chip available on the board and Xilinx provides one script
to generate the file with .ace extension which works as a bios and also loads the
bitstream into the FPGA to configure hardware onto the board before booting.
I think the bootloader also is encarporated into this file.

hilbertyhb 09-25-2009 08:54 PM

I encountered the same problem, I will appreciate for any help!

mangeshwanjari 09-26-2009 12:49 AM

This problem is due to the memory map... in my kernel the memory map created was having some addresses which were falling into the range 256 MB to 512MB and I was using 256 MB SDRAM. I have changed to 512MB memory and it worked fine.

hilbertyhb 09-27-2009 06:14 AM

Thanks for you help, I will check the memory mapping.

hilbertyhb 09-27-2009 08:54 AM

when I boot the kernel , occur

loaded at: 00400000 004BD13C
board data at: 00000000 00000018
relocated to: 00405098 004050B0
zimage at: 00405A19 004BA9BA
avail ram: 004BE000 79391000

Linux/PPC load: console=ttyS0,115200,root=/dev/xsa2 rw
Uncompressing Linux...done.
Now booting the kernel

then hangs,
I power off the board and then boot kernel ,

avail ram: 004BE000 69200000
the rest is same with above information

why? I will appreciate you if you can help me.

hilbertyhb 10-01-2009 05:15 AM

I have found the solusion of that problem, it need to change the version of ppc cross-compile tool.
powerpc-405-linux-gnu-3.4.5 is ok!

All times are GMT -5. The time now is 08:03 PM.