-   Linux - Embedded & Single-board computer (
-   -   DD-WRT and Linksys WRT54GS2V1 problems (

Norami 11-29-2009 03:04 AM

DD-WRT and Linksys WRT54GS2V1 problems
So, I have 2 Linksys WRT54GS2 routers. One is connected to the internet broadcasting a wireless signal, and the second is (hopefully) going to be a repeater for that signal. Well, I got a little eager, and didn't really research it all that much, and I think I'm paying for it now.

So I went to do the whole DD-WRT firmware upgrade. Found all the .bin files I needed to flash it, and went to town without any realy knowledge of how it needed to be done. My fault. Anyways, I started with the first file, which was VxWorksKiller-GS2V1.bin, and I don't think I let the router do its thing for long enough. I jumped the gun and restarted the router myself. Now it has no wireless signal broadcasting, and I can't even get my computer to talk to the ethernet port. I've tried resetting the router, but obviously, that's not working. I hope it's not FUBAR.

If I could just get the router to actually connect to the system, I can do the rest. If anyone has any insight on this matter that would greatly be appreciated! I don't want to go out and buy a new router if there's a fix for this.

nimnull22 11-29-2009 08:04 PM

Switch on router and try to hold pressed RESET button at least 60 second, some times it can revert it to default settings.

Second find a manual and find what IP it is used for WEB settings page. Change your computer ethernet card IP according to router LAN, then try to connect.

Norami 11-29-2009 08:44 PM

I've tried the reset button, but it doesn't work. I've also tried changing the eth0 IP in ifconfig, but it still doesn't connect to the router.

GrapefruiTgirl 11-29-2009 08:52 PM

An incomplete (or aborted) flash of the routers firmware may well have fubared it from the perspective of being able to fix it by the usual means (the www interface, the reset button way) and it might need some sort of other repair job, like removing and replacing or externally flashing the EPROM with an EPROM burner.

Anyhow, that stuff's beyond the scope of what I wanted to say, and that was just that on some routers (all ones I've ever had to reset) simply pressing and holding the reset button wasn't enough. What usually needs to be done is to hold the reset button in for at least some seconds (10-15, maybe) and simultaneously turn off the router (still holding the button) and now wait like 5-10 seconds, and turn the router back on (still holding the button) and keep holding the button until all the lights stop flashing and whatnot.

Now, if the router were able and willing to reset itself to a workable state, it should be done by now. If this doesn't work, and the router is still incommunicado, I'd be wondering if the firmware needed replacing or removal and flashing.


Norami 11-29-2009 09:03 PM

Yeah, I was afraid that I had messed it up to the point where I'd have to either find someone I know personally that can do some physical work to it, or having to send it in to Linksys. I doubt linksys would take it though, cause I sort of messed with their product, therefore voiding the warranty.

I just tried holding the reset button while turning the router off and on again, but no such luck. I vaguely remember trying to do that last night before I posted this thread.

GrapefruiTgirl 11-29-2009 09:07 PM

You **might** be interested in the above thread, or a Google search about repairing bricked router. Apparently Linksys offers a tool that can upload firmware via sftp, which might help (if you can get the tool, and if it works for your model of router) if you could dump the firmware from the good router, save it, and upload it to the dead router..

Do keep us posted :)


jschiwal 11-30-2009 10:01 AM

Moved: This thread is more suitable in Linux-Hardware and has been moved accordingly to help your question get the exposure it deserves.

All times are GMT -5. The time now is 02:49 PM.