LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Embedded & Single-board computer (http://www.linuxquestions.org/questions/forumdisplay.php?f=78)
-   -   Configuring USB bluetooth (http://www.linuxquestions.org/questions/showthread.php?t=4175430089)

humph 10-02-2012 11:21 AM

Configuring USB bluetooth
 
Hi Everyone,

I'm having an issue configuring a USB Bluetooth dongle. I've got a 3.0.4 kernel and I'm using Bluez-utils.

My current state is I can see the dongle if I run a hciconfig, giving the output:

Code:

hci0:  Type: USB                                                             
        BD Address: 99:88:66:00:1D:17 ACL MTU: 384:8 SCO MTU: 64:8             
        UP RUNNING PSCAN ISCAN INQUIRY                                         
        RX bytes:10594 acl:11 sco:0 events:281 errors:0                       
        TX bytes:1209 acl:9 sco:0 commands:190 errors:0                       
        Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80                     
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3                       
        Link policy: RSWITCH HOLD SNIFF PARK                                   
        Link mode: SLAVE ACCEPT                                               
        Name: 'CSR - bc4'                                                     
        Class: 0x020300                                                       
        Service Classes: Networking                                           
        Device Class: LAN Access, Uncategorized                               
        HCI Ver: 2.0 (0x3) HCI Rev: 0x7a6 LMP Ver: 2.0 (0x3) LMP Subver: 0x7a6 
        Manufacturer: Cambridge Silicon Radio (10)

I can also use commands such as sdptool to browse the services offered by my phone, so it appears to be working ok.

The problem occurs when I try to change any parameters in the conf file (found in /etc/bluetooth/hcid.conf). For example I have tried to change the name and the passcode and then performed a stop and start to restart the service (using init.d/bluetooth stop/start) but no change occurs at all, it still has all the values as above. I've had a search to try and find where the default values are stored (using the default name as the search parameter) but can't find anything.

Does anybody have any ideas how to change parameters such as passkey/name?

Thanks for the help

p.s. I've been using http://elinux.org/Bluetooth_Network#..._Configuration to try and set-up a piconet. Just to give some more background.


All times are GMT -5. The time now is 01:51 AM.