-   Linux - Embedded & Single-board computer (
-   -   charset problem with ts-5700 on /dev/ttyUSB0 (

t0bias 09-17-2007 09:41 AM

charset problem with ts-5700 on /dev/ttyUSB0
hi there,

i've got a new ts-5700 evaluation-board
( )
when i try to boot (using minicom, screen or gtkterm) as a terminal
i can properly see the bois ouput of the device and also normally
interact with the bios (enter setup, etc.)
nevertheless, as soon as the real boot-process starts, it gives no more
real characters but unreadable symbols.

any ideas?



( see screenshot )

michaelk 09-20-2007 10:56 AM

At first glance it looks like the baud rate changed. Have you contacted Technologic Systems yet?

t0bias 09-20-2007 12:14 PM

thanks for your reply,
yes, i contacted them, but they did not respond by now. i also thought
about the baud-rate, but i tried most if not all possible settings without
success... :cry:

t0bias 10-03-2007 06:07 AM

i've solved the problem now, technologic systems couldn't tell me what's wrong but told me to set a jumper to switch the baudrate from 9600 to 115200 what works now.
thanks anyway!

michaelk 10-03-2007 06:23 AM

Well done. What are your impressions of the board.

t0bias 10-03-2007 07:46 AM

the board itself is quite ok, it has got some minor
problems though, like for example you cannot use
the wall-mounted power-supply and the pcmcia-slot
at the same time cause the plug of the power-supply
physically blocks the pcmcia slot..

All times are GMT -5. The time now is 03:11 AM.