LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Embedded & Single-board computer (http://www.linuxquestions.org/questions/forumdisplay.php?f=78)
-   -   buildroot problem rasbery: hidden symbol `_fpioconst_pow10' isn't defined (http://www.linuxquestions.org/questions/showthread.php?t=4175491360)

golden_boy615 01-15-2014 07:17 AM

buildroot problem rasbery: hidden symbol `_fpioconst_pow10' isn't defined
 
I would like to make an image for rasbery with buildroot. I configures it with manuconfig and ran make , everything goes fine until here that I got error:
Quote:

find_exidx.c:(.text+0xbce28): undefined reference to `__GI_strtol'
/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build/libc_pic.os: In function `__ptsname_internal':
find_exidx.c:(.text+0xbd22c): undefined reference to `_itoa_word'
/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build/libc_pic.os: In function `ext_wmatch':
find_exidx.c:(.text.unlikely+0x274): undefined reference to `__GI_getenv'
/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build/libc_pic.os: In function `ext_match':
find_exidx.c:(.text.unlikely+0x9a0): undefined reference to `__GI_getenv'
/home/ehsand/saedteach/buildroot-2013.11/output/host/usr/lib/gcc/arm-buildroot-linux-gnueabi/4.8.2/../../../../arm-buildroot-linux-gnueabi/bin/ld: /home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build/libc.so: hidden symbol `_fpioconst_pow10' isn't defined
/home/ehsand/saedteach/buildroot-2013.11/output/host/usr/lib/gcc/arm-buildroot-linux-gnueabi/4.8.2/../../../../arm-buildroot-linux-gnueabi/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
make[3]: *** [/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build/libc.so] Error 1
make[3]: Leaving directory `/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/libc/elf'
make[2]: *** [elf/subdir_lib] Error 2
make[2]: Leaving directory `/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/libc'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/build'
make: *** [/home/ehsand/saedteach/buildroot-2013.11/output/build/glibc-2.17-svnr22064/.stamp_built] Error 2

my system info is as follow:
Quote:

uname -a
Linux ehsand-pc 3.10.2 #3 SMP Wed Jan 15 10:59:08 IRST 2014 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.3 LTS"
NAME="Ubuntu"
VERSION="12.04.3 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.3 LTS)"
VERSION_ID="12.04"


gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.1-2ubuntu1~12.04' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.1 (Ubuntu 4.8.1-2ubuntu1~12.04)


what should I do?

embLinux 01-16-2014 01:10 AM

what is your buildroot version? I always got random errors with a buildroot 2011 version, which just disappeared with the latest version, so i can hardly recommend to upgrade, if you are not set to that particular version.

have you tryed rebuilding from scratch? If not this can cause many (misleading) errors. To be sure, it's better to "make clean" when you change some items in buildroot.

golden_boy615 01-17-2014 05:41 AM

my buildroot is 2013.11 I changed my configuration file with one of my friends config file and then make clean and every thing goes fine but still do not know what has happened.

embLinux 01-17-2014 06:04 AM

I think just your spelling was wrong, but if you load your config file and then make clean your config is gone, and so for sure it goes wrong.

Otherwise at first glance, it looks like your toolchain doesn't fit.

golden_boy615 02-09-2014 12:13 AM

my problem gone when i built everything from the begining.


All times are GMT -5. The time now is 08:02 AM.