Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.


  Search this Thread
Old 06-27-2017, 09:29 AM   #1
LQ Newbie
Registered: Mar 2017
Posts: 6

Rep: Reputation: Disabled
Alsa & Raspberry Pi / Audio8DJ soundcard not working fully

Hello all,

I am trying to use the 4 stereo outputs of a soundcard I have, on a Raspberry pi with a recent installation of raspbian.

The soundcard is listed as supported by alsa ( and
"aplay -l" and "aplay -L" show up the soundcard and its outputs.

card 1: Audio8DJ [Audio 8 DJ], device 0: Audio 8 DJ [Audio 8 DJ]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
    Audio 8 DJ, Audio 8 DJ
    Default Audio Device
    Audio 8 DJ, Audio 8 DJ
    Default Audio Device
    Audio 8 DJ, Audio 8 DJ
    Direct sample mixing device
    Audio 8 DJ, Audio 8 DJ
    Direct sample snooping device
    Audio 8 DJ, Audio 8 DJ
    Direct hardware device without any conversions
    Audio 8 DJ, Audio 8 DJ
    Hardware device with all software conversions
The thing is that speaker-test works fine and seems to output to every channels, but I only get audio from the first stereo output of the card with the following line :
speaker-test -Dplughw:Audio8DJ -c8 -tsin
Do you have an idea what is going on ? Or what coul I try ?
I have searched but couldn't find anything working...

Thank you for your time,
Old 08-16-2017, 06:49 PM   #2
LQ Addict
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,298

Rep: Reputation: Disabled

-c8 to begin with

try -c4 and then check your other command parts pls
Old 09-02-2017, 06:42 AM   #3
LQ Newbie
Registered: Mar 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi aus9

Thank you for your reply

I did try the -c command with different numbers from 1 to 8. None would result in anything more than audio out of the 2 first outputs, even though the speaker-test didn't show any error and acted as if audio was normally outputting from all outputs.

It's too bad but now I can't try anything more because the soundcard was not mine, I borrowed it to help a friend on a project, but we ended up doing this another way as the soundcard wouldn't work...

Thank you anyways, cheers !


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steps needed to get Linux Mint Cinnamon 18.1 sound working with my soundcard (intel)? Alsa information provided. nezzabezza Linux - Newbie 6 04-20-2017 11:01 AM
[SOLVED] Alsa configuration on Raspberry Pi (usb soundcard can't play sound) pabloparis Linux - Software 2 03-17-2017 06:57 AM
alsa not working anymore: no soundcard found cuk Slackware 4 12-10-2006 08:30 AM
Alsa Drivers not FULLY working on Mandrake Rnastyracer Linux - Software 4 10-22-2004 02:04 PM
XMMS, Soundcard & ALSA maxismusp Debian 3 03-02-2004 05:06 AM > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer

All times are GMT -5. The time now is 09:16 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration