LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 04-07-2002, 05:06 PM   #1
coolguy18087
Member
 
Registered: Mar 2002
Posts: 30

Rep: Reputation: 15
Zip Disk on Mandrake 8.1


I am not sure whats going on. My zip disk was working fine when I first installed Mandrake, but apparently something must have gone wrong. When I click on my zip disk icon, I can see konqueror opening up, but I dont see any files in my zip disk. I am not sure what I messed up...here is a partial copy of my /etc/fstab file. I would really appreciate any help. Thanks

/dev/scd0 /mnt/cdrom2 auto user,iocharset=iso8859-1,exec,codepage=850,ro,noauto 0 0
/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,sync,exec,codepage=850,noauto 0 0
/dev/hda1 /mnt/windows vfat iocharset=iso8859-1,codepage=850 0 0
/mnt/zip /mnt/zip supermount dev=/dev/hdb4,fs=auto,exec,--,user,iocharset=iso8859-1,sync,codepage=850,noauto 0 0
none /proc proc defaults 0 0

FYI - My zip drive is secondary on the the Primary IDE channel
(I am not sure why there are two /mnt/zip entries, I tried removing one, but didn't help. Thanks again)
 
Old 04-08-2002, 12:42 PM   #2
DevDuck
LQ Newbie
 
Registered: Apr 2002
Distribution: Slackware!!!!!!
Posts: 1

Rep: Reputation: 0
I'm not an expert on fstab, so I have no idea why Mandrake set up the zip disk so odd. At first I thought it had to do with allowing KDE to automount, but I see your CD drive is done normally.

My entry in fstab is:
/dev/hdd4 /zip vfat user,noauto,rw 1 0
you would want to change it to:
/dev/hdb4 /mnt/zip auto user,noauto,rw 1 0
everything else you had selected there is quite superfulous in my opinion.

I also suggest to make a back-up of the /etc/fastab before you change it.

Greg
 
Old 04-08-2002, 11:12 PM   #3
burk
LQ Newbie
 
Registered: Aug 2001
Posts: 23

Rep: Reputation: 15
Here is the zip drive entry in my etc/fstab in Mandy 8.1

/dev/hdd4 /mnt/zip auto user,iocharset=iso8859-1,umask=0,sync,exec,codepage=850,noauto 0 0
 
Old 04-11-2002, 01:19 AM   #4
coolguy18087
Member
 
Registered: Mar 2002
Posts: 30

Original Poster
Rep: Reputation: 15
Still not working

Hi guys,

I have the exact same thing. First I wasn't sure if the changes actually took place or not. So I reboot and still nothing. There is a zip disk icon, and if I click it i opens up koqueror, but doesn't showany files in there. Also, I tried "mount /mnt/zip" from the command line and it return something like /dev/hdb4 not found, but Hardrake recognizes my zip. Any other suggestions for troubleshooting? I really appreciate any help. Thanks

Shiva
 
Old 04-25-2002, 05:36 PM   #5
mydini
Member
 
Registered: Mar 2002
Location: Australia
Distribution: Slackware 10
Posts: 45

Rep: Reputation: 15
Hi all,

Me too....I must have the same set up as you, coolguy I get the same message about hdb4.
I will let you know what I find out when I fiddle with it.
 
Old 04-28-2002, 11:22 AM   #6
sapilas
Member
 
Registered: Apr 2002
Location: Greece
Distribution: the best !
Posts: 176

Rep: Reputation: 30
try

dmesg | more


check to see if your zip is found in the boot process

/dev/hdb4 - primary - slave
/dev/hdc4 - secondary - master
/dev/hdd4 - secondary - slave

if not you have to recompile the kernel to enable it.

then just type

mount /dev/hdd4 /zip -t vfat ( if you have it second-slave)

(note: you must have a /zip dir of course)
 
Old 04-30-2002, 07:40 AM   #7
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 63
OK, I haven't read this thread thouroughly, but I'll add my 2p anyway. If it is an IDE/Atapi ZIP disk, then you will need to edit your lilo.conf/grub.conf. Under Mandy 8.1, I believe that by default it puts hdx=ide-floppy in the append section, but under Mandy 8.2 this changes to hdx=ide-scsi (yep, the same as for cdrw). I haven't got around to testing this under Mandy 8.1, but you could give it a go.

Oh, and BTW, if you do use hdx=ide-scsi, then your fstab entry will need to point to /dev/sdx?.

(hdx = the ide device letter, sdx = the scsi device letter).
 
Old 05-16-2002, 10:18 PM   #8
douglassparker
LQ Newbie
 
Registered: Apr 2002
Location: Derwood, MD
Distribution: Red Hat
Posts: 6

Rep: Reputation: 0
I was having the same problem in Red Hat and it
went away when I specified /dev/hdd instead of
/dev/hdd4 in /etc/fstab.
 
Old 06-19-2002, 11:37 PM   #9
terrelw1
LQ Newbie
 
Registered: Jun 2002
Location: Aloha, Oregon USA
Distribution: Mandrake 8.1
Posts: 2

Rep: Reputation: 0
I am yet another person having zip problems in Mandrake 8.1. It will mount and unmount but when Konqueror starts up I get an error. "Could not enter directory /mnt/zip". My fstab file:
/mntzip /mnt/zip supermount dev=/dev/hdc, fs=vfat,--,user,0 0
Anyone have a suggestion?

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
zip disk d3s Linux - Newbie 1 04-16-2005 09:54 AM
disk zip "device busy" - Mandrake 10 wil Linux - Hardware 7 10-09-2004 03:28 PM
Zip Disk Ian_Hawdon Linux - Hardware 8 05-21-2003 01:55 PM
Zip disk problems Mandrake 8.2) terrelw1 Linux - Hardware 0 07-01-2002 11:11 AM
zip disk-help square317 Linux - Software 1 12-19-2000 07:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration