LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Zip Disk on Mandrake 8.1 (https://www.linuxquestions.org/questions/linux-distributions-5/zip-disk-on-mandrake-8-1-a-17957/)

coolguy18087 04-07-2002 05:06 PM

Zip Disk on Mandrake 8.1
 
I am not sure whats going on. My zip disk was working fine when I first installed Mandrake, but apparently something must have gone wrong. When I click on my zip disk icon, I can see konqueror opening up, but I dont see any files in my zip disk. I am not sure what I messed up...here is a partial copy of my /etc/fstab file. I would really appreciate any help. Thanks

/dev/scd0 /mnt/cdrom2 auto user,iocharset=iso8859-1,exec,codepage=850,ro,noauto 0 0
/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,sync,exec,codepage=850,noauto 0 0
/dev/hda1 /mnt/windows vfat iocharset=iso8859-1,codepage=850 0 0
/mnt/zip /mnt/zip supermount dev=/dev/hdb4,fs=auto,exec,--,user,iocharset=iso8859-1,sync,codepage=850,noauto 0 0
none /proc proc defaults 0 0

FYI - My zip drive is secondary on the the Primary IDE channel
(I am not sure why there are two /mnt/zip entries, I tried removing one, but didn't help. Thanks again)

DevDuck 04-08-2002 12:42 PM

I'm not an expert on fstab, so I have no idea why Mandrake set up the zip disk so odd. At first I thought it had to do with allowing KDE to automount, but I see your CD drive is done normally.

My entry in fstab is:
/dev/hdd4 /zip vfat user,noauto,rw 1 0
you would want to change it to:
/dev/hdb4 /mnt/zip auto user,noauto,rw 1 0
everything else you had selected there is quite superfulous in my opinion.

I also suggest to make a back-up of the /etc/fastab before you change it.

Greg

burk 04-08-2002 11:12 PM

Here is the zip drive entry in my etc/fstab in Mandy 8.1

/dev/hdd4 /mnt/zip auto user,iocharset=iso8859-1,umask=0,sync,exec,codepage=850,noauto 0 0

coolguy18087 04-11-2002 01:19 AM

Still not working
 
Hi guys,

I have the exact same thing. First I wasn't sure if the changes actually took place or not. So I reboot and still nothing. There is a zip disk icon, and if I click it i opens up koqueror, but doesn't showany files in there. Also, I tried "mount /mnt/zip" from the command line and it return something like /dev/hdb4 not found, but Hardrake recognizes my zip. Any other suggestions for troubleshooting? I really appreciate any help. Thanks

Shiva

mydini 04-25-2002 05:36 PM

Hi all,

Me too....I must have the same set up as you, coolguy I get the same message about hdb4.
I will let you know what I find out when I fiddle with it.

sapilas 04-28-2002 11:22 AM

try

dmesg | more


check to see if your zip is found in the boot process

/dev/hdb4 - primary - slave
/dev/hdc4 - secondary - master
/dev/hdd4 - secondary - slave

if not you have to recompile the kernel to enable it.

then just type

mount /dev/hdd4 /zip -t vfat ( if you have it second-slave)

(note: you must have a /zip dir of course)

Thymox 04-30-2002 07:40 AM

OK, I haven't read this thread thouroughly, but I'll add my 2p anyway. If it is an IDE/Atapi ZIP disk, then you will need to edit your lilo.conf/grub.conf. Under Mandy 8.1, I believe that by default it puts hdx=ide-floppy in the append section, but under Mandy 8.2 this changes to hdx=ide-scsi (yep, the same as for cdrw). I haven't got around to testing this under Mandy 8.1, but you could give it a go.

Oh, and BTW, if you do use hdx=ide-scsi, then your fstab entry will need to point to /dev/sdx?.

(hdx = the ide device letter, sdx = the scsi device letter).

douglassparker 05-16-2002 10:18 PM

I was having the same problem in Red Hat and it
went away when I specified /dev/hdd instead of
/dev/hdd4 in /etc/fstab.

terrelw1 06-19-2002 11:37 PM

I am yet another person having zip problems in Mandrake 8.1. It will mount and unmount but when Konqueror starts up I get an error. "Could not enter directory /mnt/zip". My fstab file:
/mntzip /mnt/zip supermount dev=/dev/hdc, fs=vfat,--,user,0 0
Anyone have a suggestion?

Thanks!


All times are GMT -5. The time now is 10:58 PM.