-   Linux - Distributions (
-   -   Ubuntu and XP not playing nice. (

kojima 10-10-2004 09:07 PM

Ubuntu and XP not playing nice.
Ok, it's been a while since I've run linux. Several friends recommended Ubuntu to me. So, I gave it a shot. The distro is awsome, but grub refuses to load xp.

When I hit escape to bring up the grub menu I do have XP as an option. But when I select it I get:

Booting 'Windows NT/2000/XP'

root (hd0,0)
Filesystem type unknown, partition type 0x7
chainloader +1

My XP partition is NTFS

Xenoeye 10-11-2004 04:39 AM

Where did you install grub to?

Gavin19 10-11-2004 02:42 PM

Just boot into ubuntu and make sure the /boot/grub/menu.lst uses this for your xp partition -

title Windows
root (hd0,0)
chainloader +1

I have xp+ubuntu installed as multi boots on this box and my laptop w/o probs.

Tap-Out 10-12-2004 10:27 PM


The problem you're experienceing is common to a lot of different distros that ship with the 2.6 Kernel.

The solution can be found here:

Solution to 2.6 Kernel/XP Boot Problem.

Note that this link it to a site hosted by SuSE, however it does state in the document that this is a common problem not limited to SuSE.



pcoovert 10-13-2004 08:31 AM

I installed Ubuntu from the 10/7/04 build. I cannot boot to Windows. I get a result similar to kojima's.

When I installed Ubuntu it said nothing about an owner username or password. I cannot modify the menu.lst file without this information. What do I have to do to get this info?

Also, the link to the solution in Tap-Out's response does not work.


spaniard 10-13-2004 10:57 AM

sudo nano /boot/grub/menu.list
When it asks for you password type in your user password.

TKS 10-13-2004 11:27 AM

I'd go with a more mature distribution and wait for Ubuntu to get up to speed. Sure it looks installs runs great...but it needs time to mature.

Try Knoppix, PCLinuxOS, MEPIS, or Libranet

out of all of those, I run MEPIS the most. It plays nice with all versions of windows and you can install any Xwindows environment on it you want.

Tap-Out 10-13-2004 05:17 PM

I don't know why that link would not work.

Here it is in plain text, just copy/paste this in your browser window.

Just put http:// in front of it, NO www.

Really hope this helps as it has worked like a charm for me.



edit: whenever I try to just type the address the form automatically puts in the bloddy url tag which makes it a link.. how frustrating

pcoovert 10-13-2004 05:29 PM

Thanks but I still get a 404 error (in German).

I am running SuSE and so I went to the portal and found an answer that worked.

It was a matter of activating the LBA in CMOS instead of AUTO for large disk access.

This might help some of the others who are having this problem.


All times are GMT -5. The time now is 01:42 AM.