-   Linux - Distributions (
-   -   Trying to make my sshd service to work. Help please! (

babyboss 10-28-2004 05:19 PM

Trying to make my sshd service to work. Help please!
I just install fedora core 2 and tried to remote control my computer. I believe that I already install my sshd and start sshd at the boot time, but the bad news is that I can't remote login to my computer. My use shaw cable high speed internet and I also have a linksys router.
What else configuration do I have to make?
I use ntsysc to closed most services that I don't really need and I left ssh services on. Would shutting down all my services but only leave my ssh service on affect my chance to connect to my box from the outside?

slide-rule 10-28-2004 05:33 PM

You question doesn't make it clear if your problem is entirely local (two machines connected by your home router, and you can't connect from A to B) or whether it is entirely remote (attempting ssh connection across the internet through your ISP.) For the latter case, it is possible, if you're sure you've done all the right things, that your upstream provider (ISP) is blocking connections to the normal ssh port (22) on your system. If this is what is happening, you might can try running sshd on a different port than the default one, but you'll of course have to give this new port number in your ssh connect attempt from the other side.

At any rate, please clarify where the problem is. =)

babyboss 10-28-2004 05:42 PM

Sorry about that I did not make my problem clear. My sshd works if I tried to internally remote control. It does not work when I tried externally remote control. I believe that my ISP didn't block port 22 becuase I used to install Slackware 10.0 and the port 22 works when ssh

slide-rule 10-28-2004 09:09 PM

You mentioned that you closed down many/most services. Is there a firewall service running on the box that is rejected connection attempts? I'm not sure which one RH FC uses... likely 'iptables'. If not that, 'ipchains' or 'shorewall' might be culprits. If such a firewall is running, the quick check is to turn it off to test. HOWEVER, the correct solution is to allow ssh connections through the firewall (meaning, you configure the firewall to permit TCP connections from anywhere coming in to port 22). That'd be the next simple thing to check for.

All times are GMT -5. The time now is 12:13 PM.