LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (https://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   SUSE FTP install doesn't include YaST? (https://www.linuxquestions.org/questions/linux-distributions-5/suse-ftp-install-doesnt-include-yast-183734/)

TACD 05-20-2004 10:29 AM

SUSE FTP install doesn't include YaST?
 
After fixing the problem of SUSE's installer not recognizing my ethernet connection (by borrowing a RealTek from a friend), I thought I'd give the SUSE FTP install a whirl. I've been thinking about buying SUSE since I was impressed by the Live evaluation CD, but I wanted to be sure before I spent ~20 getting it shipped across the Atlantic.

I went out for the day while slowly but surely the installer downloaded a gigabyte or so of packages from the 'net, but sure enough I eventually had what appeard to be a working Linux system in front of me. Except... I didn't recall it ever asking me to set up a root password or any kind of user account. Logging in as root with no password worked but was slightly troubling.

Now, my plan had been to install the recommended 'default' system at first, and then use YaST to download / update whatever packages I wanted, so taht I could browse the 'net or listen to music while it chugged. So I wasn't best pelased when I brought YaST up and found all of the modules blank. By blank, I mean I could see where they were supposed to go - I had little buttons happily labelled 'networking' and 'package management' and all the rest of it, but clicking them resulted in quite a flurry of inaction.

I went to the KDE control panel - all was well there, I could change my desktop wallpaper to my heart's content, but once again the YaST modules did nothing, presenting me with a dull grey space where all sorts of fun configuration toys should have been?

What's going on? I tried 'updating' YaST with the same installation method but that also failed to work. Why is this vital component left out of the FTP install?

Pcghost 05-20-2004 06:01 PM

I don't know which version you were working with, but YaST only became GPL'ed in SuSE 9.1. In 9.1 it was still covered by it's other license. That could be the reason. I suspect something got corrupted in the download though. Why not try the Live Eval if you are just looking to try out SuSE?

ima 05-20-2004 08:08 PM

Yast can be kicked off in several ways. If you select Online Update then the packages are dimmed.
BUT, if you select Install and Remove software, THEN you can select all the packages you want to.

I hope it's as simple an answer as this...

Good luck, and I will check back to see how you're making out. (BTW - My 1st install was 9.0 FTP install, and YaST worked fine...)


All times are GMT -5. The time now is 04:02 AM.