-   Linux - Distributions (
-   -   SuSE 9.1 YaST2 won't load modules (

sykikchimp 08-23-2004 02:29 PM

SuSE 9.1 YaST2 won't load modules
Well, I downloaded the 9.1 Personal iso and installed that. Was running
good but slow. Found that if you use "acpi=off" when you are booting it
helps. So.. I went ahead and downloaded the updates from FTP to get the
stuff that is not supplied with personal. Downloaded around 7gb of files..

Once the update was completed, I rebooted, and now none of the YaST2
modules will load. If I'm in YaST directly I click on the module and they
say "Starting module xxxx" at the bottom of the window. It goes away, and
nothing ever loads.

If I'm in the Control Center > YaST > any section > any module.. I enter
"Administrator mode" it says "Loading..." for a while, then switches to
"YaST2 is starting up" and hangs there indefinately.

I am an ultra newbie at this. This is my first linux install. I am
currently a Systems/Network Engineer for the company I work for, and I've
been totally humbled by this. Any idea what may be wrong? I'm not even
sure where to start.

Also, they system seems to be running much slower (loading windows) now after the updates even with the "acpi=off" command
This is on a Dell Optiplex gx240 2.4ghz box.

I checked the swap file size with "free", and it appears to be 1gb. (I
didn't change it, that how it was from install.)

I sincerely appreciate any help.

ithawtewrong 08-23-2004 03:46 PM

I had the same problem and I'm seeing more and more post about this. Here's what I did to fix it and a brief history.

Hope it helps.

sykikchimp 08-23-2004 03:50 PM

thanks! I'll try that tomorrow and report back.

sykikchimp 08-24-2004 12:40 PM

Well, I tried to install it, and I get this:
sykikchimp@dhcppc7:~> rpm -ivh /home/sykikchimp/popt-1.7-176.3.i586.rpm
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm

ithawtewrong 08-24-2004 12:48 PM

I'm not sure what that message is about. Are you logged in as root?
If you are and are still getting that try restarting or closing all other applications and try it again. I'm pretty new to most of this stuff myself, so if that doesn't work you may want to ask in another post what that error about an exclusive lock is.

I think I did a rpm -Uvh filename.rpm

I'm not sure if that matters either. I'm not at a linux machine now, but I think U is upgrade, v is verbose, and h is hash marks.

You may also try running rpm from the directory where the rpms are saved.

sykikchimp 08-24-2004 01:50 PM

Ok, Tried it as root, and said installed 100%.. already installed..

Tried modules in yast, and they still don't open. Do I need to reboot??

ithawtewrong 08-24-2004 02:41 PM

Did you install just that one package or all the rpm's for Yast?
I had to install the one with the dependency and then reinstall Yast.
After the Yast reinstall it all worked for me.

sykikchimp 08-24-2004 05:30 PM

ok, I didn't reinstall. I'll try and report back. seriously thank you very much!

I need to read up a lot more.. :study:

ithawtewrong 08-24-2004 08:58 PM

Funny thing. I had it reoccur tonight.
I was installing an application and it asked for my install disc again. I put it in and it installed something very fast, but I think it was a gnome interface for Yast.
I tried to load Yast afterwards and nothing launched it just clocked.
I did each package separately this time and retried Yast. It appears that after the Yast2Core and Yast2Ncurses install it worked again.
If you saves you some download time try them first.
I must admit its kinda weird behavior. I use KDE by default so I'm not sure why it wants to install this gnome stuff.

sykikchimp 08-25-2004 01:36 PM

well, I tried just reinstalling those 2 and it still doesn't work. Which Yast rpm's do I need to re-install to "reinstall yast" there are a ton of them... :-(

ithawtewrong 08-25-2004 02:40 PM

Originally I had reinstalled ALL of the packages that had Yast in the name. I know, there are a lot of them.
The issue I had last night was resolved by reinstalling only the two I listed in my last post.
I wish I could help you more, but I'm kinda at a loss at this point. I guess you could go ahead and do the others, hopefully you've got a broadband connection.

rickokane 09-28-2004 06:45 PM

Recovered yast2
Hopelessly new at linux. I lost my yast this morning. Asked it to run and it never came up. I read some posts and I kept getting problem because it was shared (or something like that).

I finally got it back by booting from cd 1 and doing a repair. I just slowly followed the instructions and had the program check my files and the thing fixed itself.

Very pleased with the outcome!!

All times are GMT -5. The time now is 12:24 PM.