LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 12-20-2002, 12:08 PM   #1
davo111
LQ Newbie
 
Registered: Dec 2002
Location: St. Helens, UK
Distribution: SuSE
Posts: 2

Rep: Reputation: 0
Angry suse 8.1 and apache/php


Hi All

I've just upgraded to SuSE8.1 and it's completey trashed a site I've been working on.

I've got an .htaccess file in the directory I'm hitting and then several php forms accessing a mysql database.

Everything worked fine under 8.0 but now each page asks for username/password and my after the first display zip.

I think it's a problem passing variables to the forms but I can't find anywhere to check what's not been switched on / off.

The standard phpinfo() works fine, but something like

<?php
$name = explode(" ", $REMOTE_USER);
echo "$REMOTE_USER,$name[0],$name[1]<BR>";
?>

produces a blank page


Any help gratefully accepted.

steve

Last edited by davo111; 12-21-2002 at 06:42 AM.
 
Old 12-22-2002, 02:47 PM   #2
then
Member
 
Registered: Oct 2002
Location: FDR India
Distribution: RH9, Knoppix, MEPIS
Posts: 65

Rep: Reputation: 15
Hi

* Did the OS upgrade include an upgrade of PHP too?
* Which version og PHP are you running now?
* If PHP version > 4.1.0, REGISTER_GLOBALS = Off by default in your php.ini. Then your script may need to be modified or you must set REGISTER_GLOBALS = On

Please read the PHP manual for the appropriate documentation.

HTH
theN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache 2, PHP 5, SuSE 9.2 - cannot run php files dickohead Linux - Networking 6 06-28-2006 11:25 AM
Parsing PHP Scripts using Apache in SuSe 9.3 (without a dedicated server) elliotfuller SUSE / openSUSE 7 07-27-2005 12:40 PM
PHP Sessions causing trouble in Apache 2 / SuSE 9.2 Spudley Linux - Software 1 06-08-2005 02:21 AM
Suse 9 Enterprise PHP/Apache komserbey Linux - Networking 2 04-30-2005 04:47 AM
reinstalled apache, php, still no php support SuSE 8.2 hindenbergbaby Linux - Software 1 10-14-2003 02:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration