LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 10-16-2002, 06:06 PM   #1
lonestarbacon
LQ Newbie
 
Registered: Oct 2002
Posts: 3

Rep: Reputation: 0
Strange characters in Konsole under Redhat 8.0...


Here's a good one. If I open up Konsole, things like man have strange characters in places they don't belong. The best way to actually see it, is to go into /usr/src/linux-2.4 and run make menuconfig. That causes funky chars on my 2 linux boxes every time.

Does anybody else have this problem?

-Brian
 
Old 10-17-2002, 03:29 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Such problems appear when you have not-English language set and not all fonts support the encoding (after you change font in the console it should be OK).
 
Old 10-24-2002, 04:43 PM   #3
kenb
LQ Newbie
 
Registered: Oct 2002
Location: Lexington, SC
Distribution: Fedora, Red Hat, SuSe, Slax, Ubuntu
Posts: 5

Rep: Reputation: 0
RH 8.0 garbles Konsole characters

Yes. I also have this same problem. I simply upgrade a 7.3 system to 8.0 and Konsole does not refesh the screen correctly. Nor does it display characters correctly. I can not even attempt to read a man page, because it is so badly mangled on the screen.

My country and language are USA and English US, respectively.

Changing the font/keyboard/size/schema all do no good to correct this problem which the upgrade broke, nor does 'stty sane'.

While good ole reliable xterm works flawlessly, I haven't a clue how to undo what damage the upgrade has done to Konsole.
 
Old 10-30-2002, 02:32 PM   #4
kenb
LQ Newbie
 
Registered: Oct 2002
Location: Lexington, SC
Distribution: Fedora, Red Hat, SuSe, Slax, Ubuntu
Posts: 5

Rep: Reputation: 0
Konsole refresh problem SOLVED!

Thanks to a buddy this problem can be corrected by setting the Konsole font to a Custom fixed font.
 
Old 10-31-2002, 03:11 PM   #5
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Rep: Reputation: 15
Same problem while using fixed font

I am using fixed fonts (I think): monospace. I think this is the font Konsole uses (in RH 8) by default. I also noticed the problem while looking a man (apt-get) file.
 
Old 10-31-2002, 03:21 PM   #6
kenb
LQ Newbie
 
Registered: Oct 2002
Location: Lexington, SC
Distribution: Fedora, Red Hat, SuSe, Slax, Ubuntu
Posts: 5

Rep: Reputation: 0
Correct Konsole with "Custom" fixed font

Rimmer,
There are several places within Linux to affect the fonts.
However, to effect the Konsole you must select the Konsole "Settings" menu and then "Font".
To correct this problem, choose "Custom" under "Font",
then select "Fixed", of which there are three varieties.
I am using "FIxed [Misc]"

Hope this helps,

Kenb
 
Old 10-31-2002, 05:37 PM   #7
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Rep: Reputation: 15
No Fixed fonts in Konsole

I don't have the option of selecting those fonts in Konsole. I chose monospace because its listed as a fixed width font in the KDE fonts control panel.

My list of Konsole fonts is:

Andale Mono
Several Courier fonts
A couple of Lucida fonts
Monospace

Where do you get Fixed fonts?
 
Old 11-01-2002, 09:50 AM   #8
kenb
LQ Newbie
 
Registered: Oct 2002
Location: Lexington, SC
Distribution: Fedora, Red Hat, SuSe, Slax, Ubuntu
Posts: 5

Rep: Reputation: 0
Rimmer,
Funny, I don't have any Monotype listed in my Konsole Custom fonts, even though it does show up under the Look&Feel of the Control Panel. Lucida and Courier both cleared this problem for me as well. I t ried a few other that worked too. It seems that choosing a Custom font may be all that you need to do to fix the problem under Konsole.

Kenb
 
Old 11-01-2002, 01:16 PM   #9
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Rep: Reputation: 15
Lucidatypewriter works

Unfortunately its my least favorite font selectable from Konsole. The Courier fonts (and even Lucida Console) still give me strange characters. Anyone know how to add more fonts to Konsole?
 
Old 12-29-2002, 09:24 PM   #10
spenner
LQ Newbie
 
Registered: Dec 2002
Posts: 2

Rep: Reputation: 0
Actually Several Font Problems With KDE 3.0.3 Under RH 8.0

I, too, have seen not only incorrectly displayed characters on the Konsole (particularly when viewing man pages), but also persistent little bits of characters left over and scattered about the screen. In some cases, "black rivers" actually run through characters - the truncation points are very clear in displays of dense text.

In addition, when I try to use Konsole with minicom to communicate with an embedded system over COM1 (/dev/ttyS0), the minicom uses incorrect characters, and the embedded system fails to recognize <Fx> keypresses at all (eg <F1>, etc.).

The problem began with the installation of RedHat 8.0 (with KDE 3.0.3, Qt 3.0.5, and Konsole 1.1.3). I use the "Linux" colors (white text on a black background). I have tried all of the following to eliminate the problem:

1) Change fonts, using the "Custom" selection in the Konsole "Settings"-"Font" menu. My custom fonts are the following: Courier, Courier 10 Pitch, Lucidatypewriter, Luxi Mono, and Monospace. (No fonts with the name "fixed" are available.) All of these fonts appear =usually= to fix the "screen scat" left by the standard Konsole font, but only Lucidatypewriter =usually= displays characters correctly in man pages and in minicom. I have on occasion seen the "black rivers" and "screen scat" even with the Lucisatypewriter font...

2) Point KDE and Konsole at the correct font directories in the file "/etc/X11/X86Config": They should all start with the path "/usr/X11R6/lib/X11/fonts/...". This fix actually seems to have eliminated the old "could not find font -misc-16-..." error that I saw in other postings. (Or perhaps the upgrade actually traded that error in for this new set of font errors :-) )

3) I have tried checking and unchecking the "transparent" attribute in the "Settings"-"Configure Konsole" dialog box: the scat and black rivers remain with the standard Konsole font.

Would anyone from the KDE development team like to weigh in on these issues? Konsole used to be such a clean, flexible console presentation application. I saw one posting elsewhere that suggested downgrading Qt from 3.0.5 to 3.0.4, but I have not yet tried this...

I would greatly appreciate any help in this area!

Thanks.

-Steve
 
Old 02-04-2003, 12:38 AM   #11
jpiel
LQ Newbie
 
Registered: Feb 2003
Location: North of Chicago
Distribution: Arch Linux, on over a dozen machines, some with over 840 days of uptime
Posts: 2

Rep: Reputation: 0
I'm having similar problems, including viewing man pages, and viewing man pages using a php script.
 
Old 02-04-2003, 02:21 AM   #12
spenner
LQ Newbie
 
Registered: Dec 2002
Posts: 2

Rep: Reputation: 0
Possible Solution

I searched in a lot of places on the Web for answers, and finally found that the following combination seems to work OK for me:

1) I use the Lucidatypewriter font for Konsole.

2) At the end of my ~/.bashrc script, I include the line:
"export LANG=en"
Note that this modification to the bash startup script must be applied for every user on the machine , including root, in order to prevent the problem from occurring for those users as well.

I hope this helps.

-Steve
 
Old 02-04-2003, 05:45 AM   #13
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 623

Rep: Reputation: 31
I have the same problem in redhat 8.0, I use gnome and there is no Konsole which is for Kde, ( my keyboard is french ) the problem is whith the Alt-gr key
.
in the terminal there is no option to choose the font

I notice when i hit b and alt-gr, it gives a double quote a long list of b like "bbbbbbbb


where to fix the problem

thanks for help
 
Old 02-11-2003, 01:29 PM   #14
facemann
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Rep: Reputation: 0
just change /etc/sysconfig/i18n
LANG="en_US:UTF-8" to
LANG="en_US" and your console should look fine.

Of course you need admin rights for this....

Facemann
 
Old 07-09-2003, 02:11 PM   #15
EdK
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat
Posts: 1

Rep: Reputation: 0
I had the same problem with junk in Konsole after upgrading to RedHat 8.0. I fixed it by eliminating the /etc/profile.d/lang.sh file. I'm a total newbie, so I don' t know what other effects this will have.

As a result of eliminating this script, the LANG environment variable is no longer defined, I'm hoping that anything that was using it will simply default to English.

Ed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange characters in man pages _maco_ Linux - General 2 06-01-2009 06:44 PM
strange characters while loggin in through ssh legolin Linux - Networking 3 08-14-2004 03:39 AM
aterm displays strange characters juzefino Linux - Software 1 07-14-2004 11:06 AM
KDE Konsole adding extra characters Tiyogi Linux - Software 2 04-26-2004 04:21 PM
Strange Characters : RedHat 8.0 UberPhreek Linux - Newbie 1 10-18-2002 06:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 09:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration