Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions
User Name
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.


  Search this Thread
Old 11-20-2002, 07:47 PM   #1
Registered: Aug 2002
Distribution: ArchLinux 2007.08 / Slackware 11.0
Posts: 58

Rep: Reputation: 15
RH 8.0 Grub bootloader options

After my previous use of Slackware and the use of LILO, the new GRUB bootloader in RH8 is more than i know what to do with. The installation went fine......the only option when starting GRUB was "RedHat 8.0 2.4.18-14". That option booted my machine exactly the way i wanted it to. After i installed the updates from RH dot com, the GRUB options have changed. Now i have "RedHat 8.0 2.4.18-14.8.0" in the list. Not only is it now on the boot list, but it is DEFAULT. If i choose this new kernel to boot, it hangs in the init process. I have to use that nasty RESET button on the computer to make it do anything. If i select the other option that WAS the default kernel, it boots just as it did before and loads the OS properly. In X i try to access the Bootloader options, but as with other bootloader options, if i change the default listing, NOTHING CHANGES. No matter what I type in, I cannot change the GRUB optons. Can anyone help me? or is this a lost cause?
Old 11-21-2002, 05:32 PM   #2
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
The Grub configuration file is /boot/grub/menu.lst. Use your favorite GUI text editor (i.e., kate, gvim, xjed, etc.) to open it or open a console or at the command line use an editor such as vi, jed, joe, (and a cast of thousands of others).

There is an entry called "default=" followed by a number. that number corresponds to the "stanza" used to control booting of one OS or another. The number is zero indexed, so the first stanza is "0", the second is "1", and so on.

Just edit the file and change the "default=" value.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 09:53 AM
Default Bootloader Options in MDK10 Panik-Linux Mandriva 1 08-17-2004 05:05 PM
bootloader options ieuuk Mandriva 2 08-17-2004 12:09 PM
Mandrake 10. Bootloader options joshy Mandriva 2 08-05-2004 09:16 AM
bootloader options rcerrillo Linux - Software 2 03-07-2004 06:16 PM > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 01:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration